Model A1285 / 8 or 16 GB capacity

232 Questions View all

Not holding a charge, replaced battery and nothing changed

So, ipod not holding a charge, replaced battery and will still not hold a charge.

Any thoughts?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

I still haven't given up on this. Now I actually have more then 1 ipod with this problem.

None will hold a charge even with new batteries and after charching for hours.

There must be some resistor or capacitor responsible for drawing current to the battery but which one?

I know I could solder a new one if I knew which one!

I'm tempted to use a multimeter on a working one and compare all values to a faulty one. Very tedious and time consuming though :(

by

Add a comment

1 Answer

Chosen Solution

It may not be charging, Check your battery connection on the logic board for corrosion and proper fit as well as the whole logic board. Check your USB cable for any cracks etc, check your port connector for any bend or loose pins. And yes, you may have a bad battery

UPDATE

BOL take a look on here see if this will help a bit. It does point out the power management IC, I could see that there is a charging fuse similar to the iPhone on the logic board. I would check the area around the IC and see if you have an open fuse...Hope this helps, good luck.

Block Image

Was this answer helpful?

Score 0

Comments:

I've replaced it with another battery and still not charging. Maybe the charging circuit? How can i check it?

by

Check on pinouts.ru there is a schematic for the connector that would allow you to measure the output on your dock connector. So disassemble it, plug it into the USB port and use your multimeter at the dock connector and see what you get you could follow the traces and measure the output on the battery terminal. Little tedious but should work.

by

Add a comment

Add your answer

BOL will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,837