Water damage wont turn on

I got this ipod from a friend who had washed it. when she washed it she tryed turning it on before it had a chance to dry. when i plug it in to the charger the apple logo flashes on once quickly and then off and then the apple logo will turn on and stay on for a few seconds and then it turns off again and it just keeps doing this. But i had it sitting in my closet for like 5 months and just 4 days ago i plugged it in and it worked fine. the only thing is the battery didn't fully charge, and it slowly lost all its power and wouldn't charge any more. and now its doing the same thing it did 5 months ago! Is the battery causing all the problems? I'm planning on buying a new battery but i don't want to waste my money if this isn't the problem. Thanks in advance for any help.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Ethan, first thing I would do is to disassemble the Nano and clean the logic board and all connectors and cables of corrosion with isopropyl alcohol and a brush, also pay close attention to the cable ends, they do like to corrode as well. Then I would most certainly replace the battery first and see how it goes from there. It does sound to me that you have a charging issue which could originate with the battery but has further possibilities of a bad logic board charging circuit. So go battery first, it's cheaper. iPod Nano 5th Generation Battery Replacement

iPod Nano (5th Gen) Replacement Battery

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ethan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 2,371