Released on September 19, 2014, this 5.5" screen iPhone is the larger version of the iPhone 6.

1196 Questions View all

Screen Problem, vertical stripes

It was not reseting (error 4005), I replaced the battery and did reset without screen, and it worked. But when I plugged the screen back in, I got this strange issue. Note that the phone never hit the ground, it's in perfect conditions. I've tried to disconnect and reconnect all the cables, but nothing changes. Any clues ?

https://imgur.com/a/0VjPp

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

2 Answers

Chosen Solution

Update ! I already had the cables properly connected. I just asked for help in a local store, they told me that should just be static electricity (?) stored in the screen. In 1 week it seems to have discharged itself, and now the screen I working perfectly. Hope this helps !

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

Either the screen is not plugged in properly or the screen is damaged.

Unplug the battery and plug it back in and see if that helps.

Was this answer helpful?

Score 2

Comments:

It's kinda strange here. This does not resolve the problem, but when I only connect the screen cable (so 1 connected and 3 disconnected), the screen shows the same, but with more pronounced lines. And now that's what happens when I plug it all back in : https://imgur.com/a/NAfmS

by

the cable is not seated properly, try cleaning out the connection on the board and ensure the connector from the screen is flat (not bowed) before installing

by

Add a comment

Add your answer

Talerant will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 41