Model A1419 / EMC 2806 & EMC 2834/ Late 2014 or Early 2015 or late 2015 / 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 Processor / Retina 5K display

170 Questions View all

I cannot reinstall my iMac, keep getting error!


What ever I do, I keep getting this error when trying to reinstall the OS: "an error occurred while preparing the installation. try running this application again"

I have tried the following:

-Disk utlitity, cleaned the drive to Mac OS Extended (Journaled).

-Internet recovery - Getting the same error.

-Booted the iMac - so it installs the OS that came with it (El Capitan). Same error!

-Downloading MacOS from app store from 2 different macs, putting it into a USB (Bootable) - getting the same error.

Tried re-downlading the app 3 times!

-Going in to terminals, typing in "date". The date is 100% correct.

Looks like I am out of luck... anyone who can help

What else can I do? I have tried for several hours, but it wont let me install the OS?

Update (12/20/2017)

Tried doing the PRAM reset aswell two times (Boot sound coming 3 times)

Currently I removed my Crucial RAM´s. Trying again now to see if it works.

Also, did the "ntpdate - u com"

Hopefully this does the trick

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

I have spoken to four different Apple support technicians for a couple of hours. They gave up - and had to call in an Apple engineer.

We made an appointment that he would call tomorrow morning.

In the meantime, I wanted to try to resolve this myself.

The solution:

In Disk Utility in recovery mode, I saw "Fusion Drive".

I made a partition, so that I had two separate drives. HDD and SSD. Actually, I had tried this earlier - but I got the same error. However, the different method I did this time was erasing the SSD to APFS format.

Yes, you´ve probably read that Fusion Drives do not support APFS. But it won´t work when SSD and HDD is in "Fusion Drive"-mode. So you have to actually split FD.

I tried installing MacOS once more - And it worked!!

Hopefully someone will find this useful. Internet recovery, changing date, booting USB to iMac etc won´t work - try this!

Was this answer helpful?

Score 0


@henrikmeister - So that was the piece that was missing! You have a Fusion Drive config here!

You can still recover it by booting up with Sierra and reformat the SSD back to the correct Journaled partition type. Then install the OS onto the HDDD (still in un-fused state). Then rejoin the SSD to the prepped HDD into a Fusion Drive if that is what you want.


Add a comment

Something just doesn't add up here did you replace the HD?

I think you don't have any choice here. You'll need to visit an Apple Store to see what they can do to fix your system.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Henrik will be eternally grateful.
View Statistics:

Past 24 Hours: 22

Past 7 Days: 47

Past 30 Days: 111

All Time: 216