Repair manuals for tablets manufactured by Samsung, running operating systems other than Android.

66 Questions View all

Why can't I update any apps?

My tablet does not have the Google play app on it. It is an SM-T280 I've tried doing a software update along with trying to download the app from my browser with no success. Without the play store, I can't seem to update apps, or install apps. Anyone have this problem also? Or know how to fix this?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

1 Answer

Chosen Solution

You likely have a model from mainland China.

The easiest away around this is to install the Amazon app store and use their store.

• go to Settings --> Security --> enable Apps from Unknown Sources.

• download amazon app store from

• use the samsung file manager and install this apk

Otherwise, here is how to get Google Play Store.

• go to Settings --> Security --> enable Apps from Unknown Sources.

• download

• download

• download

• download

To download each APK file, just click on the link, and then scroll down where you’ll see Download APK. Click that.

Install the above 4 files with the Samsung file manager in the following order:

Google Account Manager APK → Google Services Framework APK → Google Play Services APK → Google Play Store APK

You should see the play store on the home screen now.

All you have to do now is just tap on your new Google Play Store app, and sign in with your Google account.

You may find that it might not work at first, but it will be alright after you’ve signed in.

Was this answer helpful?

Score 1


I have tried repeatedly to download the play store app itself and all I get is a little sign that says that it wasn't installed. It worked wonderfully for the amazon app but i was really hoping to get the Google play app :( the amazon app just doesn't have some of the stuff that Google does


But thank you so much for the help


@alexf1x1t, did you install all 4 files I provided in the exact order? If so, try a a different google play apk. Apparently, there are 4-5 variations. One of these should install.


Add a comment

Add your answer

alexbushell will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 15

All Time: 518