Skip to main content

How do I "Jump" the logic board to bypass the power button?

Hey everyone.

I've been trying to troubleshoot a dead PowerBook g4 12". The machine is dead. Not powering on, and has no signs of any obvious reason for this.

So far I have wittled it down to a logic board replacement, as the DC lights up, and charges the battery.

Before purchasing a new logic board, I have been advised by an friend at the Apple Store to try "jumping" the logic board to bypass any chance of it being a top case power button issue. He explained it was two contact points on the logic board that when connected together, would bypass the power switch, ensuring its nothing obvious. He then reccomended ifixit for teardowns.

I cant find these contact points, or any documents showing where these points are!

Does anyone know where I can find these?


Answered! View the answer I have this problem too

Is this a good question?

Score -1
Add a comment

2 Answers

Chosen Solution

Look for the Universal Power Symbol on the logic board:

Was this answer helpful?

Score 1
Add a comment

It's right below the keyboard socket. I have used this trick and it worked on a system I had. In my case, I assumed that the power button was bad, but I was able to see the button contacts closing using a ohm-meter on the keyboard connector. The only thing I could figure was the socket or circuit on the logic board had an open.

I soldered a pair of wires from the power button directly to the contacts on the motherboard.

When you find the contacts, just use a small screwdriver to jump the contacts.

Was this answer helpful?

Score 1


You are amazing Glenn. :) Worked for me to, but there was no picture and no start sound. Actually I tried it without a harddisk and just an external keyboard.

I heard the typical optical drive startup sound and a sound like a short "boo-beep".

The led in the display opening button lighted up.

That was it....

Any hints?


I'm not an expert with these, but it sounds like you have a deeper problem. If the power button works by jumpering on the motherboard, that tells me that we are bypassing some circuitry on the motherboard. If that circuitry is bad, there's a good possibility something else is bad, which is what sounds like is happening to you. (I hope that made sense)

Try removing anything else you can. Remove / replace memory, disconnect anything else you can including internal devices like optical drive. I think you have to have memory installed, so either replace them or remove one at a time.


Do you have a picture of where the pads are below the keyboard socket? I don't see anything that resembles pads below the socket.


Add a comment

Add your answer

Jonny will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 2,936