*The* place for Xiaomi smartphone repair guides.

259 Questions View all

Not able to boot up Mi Max Prime

I successfully flashed my Mi Max prime ROM using mi flash in edl mode. Now the problem is the phone doesn't start up. It shows mi logo and android logo down the screen, its loading dots go for a few seconds, it vibrates, and then it switches off.

I tried these ROMs:

Xiaomi Mi Max Prime 64G/128G Latest China Stable

Xiaomi Mi Max Prime 64G/128G Latest Global Stable

and also its stock rom

I tried even with miflash beta tool.

I also tried going to recovery mode and wiped all data after flash. but it seems nothing works.

but everything gives the same result.

now I can't even charge my phone. I don't know what to do if battery drains...

any suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

1 Answer

Chosen Solution

It turns out the problem is with the battery. the connector that connects the battery to the main board was damaged. so I guess it didn't provide enough output for the main board to go online!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ali Bordbar will be eternally grateful.
View Statistics:

Past 24 Hours: 4

Past 7 Days: 25

Past 30 Days: 145

All Time: 552