1.8GHz dual-core Intel Core i5 (Turbo Boost up to 2.8GHz) with 3MB shared L3 cache

265 Questions View all

MBA Fan not working

Hi, my MBA 13” mid 2012 4GB 1.8 GHz Core i5 stopped working. A friend of mine changed the I/O board and the logic board and it worked for a while, slower upon starting but overall ok when it got going.

I didn’t use for a while and then when I tried to start it, some strange lines appeared on the home screen, fan kicked in at high speed and it went black!

My question is: where is the tempreature sensor on this laptop and how do I know if the fan is working?

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

I think you have something deeper than a thermal sensor or fan issue.

To answer your question: Your system has a few sensors distributed across the logic board, the battery, and within the CPU its self.

Can you tell us why your friend changed the logic board. Did you have a liquid spill at some point?

Was this answer helpful?

Score 0

Comments:

Hi Dan,

We changed it because it went black after 3.5 years. I tried the usual resetting SMC, PRAM and then we changed the I/O board, still nothing. Only when we chance the logic board it worked.

(We put in a used one.)

I know this machine is pretty much gone, I’m investigating the reasons for it to stop working twice in such a short time to be due to same reason, that is perhaps the fan or the temperature sensor is faulty.

Thank you for taking interest and trying to help.

by

Add a comment

Add your answer

Chief will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 27

All Time: 27