Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

937 Questions View all

SSD Suddenly not working internally

I have had a Samsung Evo850 250gb for a few months now in my main drive slot. I have a dual drive system. A few weeks ago my laptop started acting up becoming very slow and the beach ball was everywhere. At some point while restarting in attempt to fix the issue, my laptop booted on the HDD instead of the SSD. I checked Disk Utility and it said the SSD was unformatted (sometimes it doesn’t even show in disk Utility). I extracted the SSD and connected it externally and it worked perfectly. I put an HDD in the main drive slot (in order to see if the hard drive cable is working) and it also worked perfectly. I cloned the SSD then put it inside again to reformat. I loaded the recovery mode and started erasing the drive but I get this : “Erase Proccess has failed”, when I view details I see this: “device not configured, couldnot mount disk after erase, formatted failed”. Now I really don’t know what to do. I checked that the SSD is fine and I made sure that the cable is also fine. What now?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

2 Answers

Chosen Solution

I know you said your hard drive cable was fine but it is the main suspect here. I would change it to the part # listed here: also put some small pads on either side of the cable as it climbs onto the optical drive to prevent the bottom from hitting it. For a while, even Apple was replacing this cable for free without question.

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable Image

Product

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable

$44.99

Was this answer helpful?

Score 2
Add a comment

I would suggest the following first:

a) If you have access to a PC, connect the SSD internally. Install Samsung Magician and fully check the drive.

http://www.samsung.com/semiconductor/min...

b) make sure your firmware is up to date.

Now if those 2 check out, look into replacing the actual hard drive cable that connects the SSD to the logic board. @danj may provide more tips on this issue.

Was this answer helpful?

Score 1

Comments:

@avanteguarde - This is a common response from a bad HD SATA cable. place some electricians tape where the cable crosses the upper case as the machined aluminum tends to rub the cable.

by

Add a comment

Add your answer

Omar will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 25

Past 30 Days: 150

All Time: 477