Repair guides and support for LED, LCD, HD and other Vizio TVs.

278 Questions View all

Vizio E470i-A0 vertical lines covering entire screen

I was wondering if anyone had any idea what could be wrong with this Vizio TV. Vertical multicolored lines take up the entire picture, i cant see the menu or any inputs. I searched around and couldnt find my exact problem . Some people say the main board needs to be replaced or the t con board. Couldnt find a t con board, the ribbons from the main board seem to connect directly to the screen.

Block Image

Block Image

Block Image

I noticed one of the ribbon cables looks burnt, or maybe its just the discoloring of the plastic. I plan on buying a new part either tomorrow or monday. Anyway, here are more pictures:

Block Image

Block Image

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Chris Santiago this model has the T-con board right on the power board. We cannot see enough details of your board to evaluate for bad caps etc. So closer images may work. this error could be T-con failure but since there is no active video showing on any area it could also be a video processor issue from the mainboard. I'd start with the power/T-con board

Was this answer helpful?

Score 1

Comments:

Thanks for pointing that out, i couldnt find much on this particular model. I can send videos or pictures of whatever you need. I just wanted to make sure it wasnt a lost cause before i bought parts i couldnt return.

by

Chris Santiago I do not think that this is a panel issue which would be the only reason for this to be a write-off. I'd buy a power board from a place where I could return it if needed first .

by

Check the two components marked FP1 and FP 2 on the top right of your mainboard for continuity. Those are fuses. Looks like TCon is on your main board. If those two ribbon cables on the right side go to the panel then that is your T-con

by

It was the main board, just swapped it out and the TV works perfectly. the part was $65 but i got the TV for free so i cant argue with it. Thanks!

by

Add a comment

Add your answer

Chris Santiago will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 71

All Time: 71