Microsoft's third-generation Xbox game console, released November 22, 2013.

251 Questions View all

Won’t read movies

My Xbox one does nothing when I insert a movie , when I click on blueray player, error message can not read. Tried redownloading software.

I have a 360s that does the same thing. I also tried cleaning eye with one of those cds w/sweepers.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Does it read game discs OK? Could be the laser's dead.

by

It reads games. And if reinsert a movie several times it will sometimes play

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

@leatherhead35 sounds like a bad laser and I am sure you have tried multiple other DVD's. I am sure that the console guru @tronicsfix can give you a better answer.

Was this answer helpful?

Score 0

Comments:

Yep, it's likely a bad laser

by

Add a comment

Add your answer

L.Golden will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 29

All Time: 29