Skip to main content

Fix Your Stuff

Right to Repair

Store

1.83, 2, or 2.16 GHz Core Duo processor

356 Questions View all

Fans run at 6000 rpm, CPU is cooled, but never slowdowns fan.

Hi everybody,

my A1150 is running fine except for the fans, they're always rotating with topspeed.

I tried resetting the SMC and PRAM, tried fancontrol and the like, but the results stay the same:

As soon as I turn on the machine the fans are spinning at topspeed and never slow down thus keeeping an intense noise level :-(

CPU temperature is 25 to 35 degrees C° at max, so far so good, always a 'cool' MBP.

My thoughts are: fans are ok, cooling is ok, sensors are ok, otherwise the machine wouldn't be so cold.

But what is wrong then ?

Thanks for a hint

CeeGee@gmx.de

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

it actually could be broken temp sensor... it gives wrong readings, so system just speeds up the fan. also, are you sure, the fan is working properly? i know, it spins, but it could have the sensor for RPM wrong. check the speed of fans against the FanControl...

also, you might want to consider reinstalling your system. i once have done very quick reinstall, using hard drive from different macbook. worked for me, don't see the reason, why it wouldn't work for you...

also, check the grills, it might me clogged...

Was this answer helpful?

Score 1
Add a comment

Add your answer

Christoph will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,935