Repair and disassembly guides and support for dish washing appliances.

219 Questions View all

Whirlpool Dishwasher stops after filling with water

My dishwasher stops running after it brings hot water in at the very beginning. Sometimes, it will start and stop various times (I suppose, continuing on through consecutive stages, but I can't be sure what it's actually doing because it rarely ends with clean dishes) across many hours. Other times, it never gets past this initial intro stage.

A few times in the past, I had success at cutting the power at the breaker, and then it tended to work perfectly for a handful of times afterwards before it would start acting up again. This last time I tried to cut breaker, however, was unsuccessful, and now it won't get past that first stage (which I always have to hit cancel to drain the water, which luckily still works every time). --Funny but not, I broke the breaker switch flipping it too many times, so I had to replace that today.--

By the way, it opens the soap tab after 5 or 10 minutes, even if it's not running/washing. So, some aspects of the "wash" cycle are working, I guess.

All panel lights are working and displaying on top.

Whirlpool Gold

Model: Wdt710paym

Only 3 years old.

Thanks for any help!

Answered! View the answer I have this problem too

Is this a good question?

Score 9

Comments:

Could you try referring to your user manual and see if it is in the troubleshooting area?

by

Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

4 Answers

Chosen Solution

Don't go with the control board on this! It seems like that is what it should be, but in most cases - replacing the wash motor is actually the answer. Especially in the cases where the dishwasher fills, soap dispenser opens, etc...

For whatever reason - Whirlpool did not include any type of motor feedback circuit on these models. The motor has a weak/poor internal connection, and is not running when it is under a load(i.e. - full of water). Because there is no feedback circuit - the control board is still sending the voltage down, and 'thinks' that the wash motor is running. It will go through all of the other cycle functions normally, but you will obviously have dirty dishes at the end of the cycle. These cycles go for 3+ hours too -

The part that I am recommending in this case is called the 'Sump & Motor Assy'. You will also need a complete model number when you find this part! You are missing the final digit in the model number provided. Open the door and look inside at the edge of the tub on the right or left-hand side. The final digit will be a number - 0,1,2,3,4,5, or 6. These are all different versions of the same model, and the part number will vary, depending on the version. Hope this helps -

Was this answer helpful?

Score 6

Comments:

Boyd, I am having a similar problem as them. I will start a load and it will fill with water. Water doesn't seem to heat up in the bottom. Washer never runs. After 1 hour (appx) it drains then adds more water. RUNS for about 5 minutes. Then drains and refills. Then it ran for another 10-15 minutes before I opened the door to see what was going on inside. The bottom was spinning. Could not tell if the top was spinning or not, it may have been (or the bottom spun it).

Here are my thoughts:

- is the heating element bad? After 5 minutes of water sitting in the bottom it wasn't hot to the touch

- does it need to sense hot water to start the wash cycle?

- if it doesn't start the wash cycle after (appx) 1 hour does it just move along to rinse (or start the wash)?

We haven't been using this for months but I am ready to get it fixed. Troubleshooting is always the hardest part.

Symptoms were: dishes not clean, long loads, soap residue on inside of front door.

by

Hi Dan -

Are there any flashing lights happening on the console after the wash cycle has "completed"? If this is the same/similar model, and the heat circuit is not functioning - you should see a light flashing several times in succession when the cycle is over. It may stop early in that case as well.

If the lower spray arm is turning, the wash motor is definitely running. There are a few possibilities depending on the scenario.

1. Does the drain go down through the floor or go over to attach to the sink? Floor drains are ALWAYS SUSPECT to siphon water out slowly = all of your symptoms. Way to test: Repeat this 2-3 times if necessary. Start cycle and let it fill. Open door. 'Cancel/Drain' - close the door. Let the drain pump run for 10-15 seconds at least. Open door. Watch the water level in tub for 5-10 min. Should not move.

2. Inlet water temp should be in the range of 90-120 degrees coming in.

3. Restricted water flow coming to the unit, or a faulty inlet valve.

4. Weak/faulty wash motor.

by

When I was checking for the part on whirlpool; kitchen aid and frigidaire also came up. I would assume it’s probably the same issue - if in fact the dish washer “acts” like it’s running the cycle and completes the cycle but the dishes are still dirty. I also opened the door about 1/2 hr into the cycle to see that there was warm water in the tub with humidity but nothing was spraying or splashing.

Granted your dishwasher is 10 years old so depending on how much you want to sink into for repairs, you may be better off just getting a new one for around $400. I took a gamble and ripped mine apart with a YouTube video (I also cleaned the sensors) and the material was only $120. Kinda up to you what your next steps are and how much patience you have with assembly. Best of luck and report back with what you decided to do. It always helps he next person searching :)

by

Boyd, I went ahead and ordered the sump and motor assembly from repairclinic and this did the trick! Thank you for helping me get it solved. The fix was super easy after watching a repair video on youtube. Only took me about 20 mins.

Dan

by

Add a comment

This was exactly the problem with our Whirlpool dishwasher. I bought the sump and assy from sears parts website and boom it works again. Same issue where it would load with water and just sit for hours sometimes before it would drain but it never would run the cycle in between with the sprayer(s). Didn’t matter what cycle I placed. I tried unplugging it, plugging it back in and no dice. So thanks for the answe cause a $750 dishwasher we bought and I replaced the piece at $120 instead of buying another dishwasher!

Was this answer helpful?

Score 1
Add a comment

Putting this here hoping it may help someone not waste their money on a pump that won’t help.

All the people who are stating it’s the latch are correct, my whirlpool gold series washer started doing this and after pulling it apart I’ve come to the conclusion that what’s happening is the metal lock tab is wearing down the plastic latch in the door and it’s no longer able to depress the latch far enough down to reset the mechanism.

You can tell if this is the case on your by the ways it sounds when closing, mine started making a light thud noise, it is supposed to make a louder clack noise.

Two ways to solve this is to either buy the latch piece and install (easy peezy like half hour tops) or be cheap like me and get something small (I’m using a small star screwdriver, the kind of point used on eye glasses screw or slightly bigger) and push in lightly on the side of the latch and you should hear a click then close door and listen for the clack and start washing

Update (11/22/2018)

Forgot my model, it’s WDT720PADB2, latch for it is like $25 cad

Was this answer helpful?

Score 1

Comments:

Same problem.. will definitely try latch first after reading all of the IDENTICAL complaints... Just amazes me .. Of course they wanna sell you $125 parts instead of a recall, shoooot.. Thanks again! Will update post door rigging ;) PS - Whirlpool

by

Tyler - Thank you! Yes!! I just tried the tiny screwdriver and the latch mechanism snapped very loudly, I've never heard that sound before! Can't wait to test it tonight ;-)

by

By pressing down on the latch, it clicked and made the door handle lock. Did I do the right thing? The door won't close unless I squeeze the handle and undo the click. And still, the washer doesn't work after closing the door.

by

@capps I’m not familiar with that issue as the issue I posted is the only one I’ve had to deal with so far, so you may have an issue that is possibly different than mine.

I just want to let it be known I am a mechanic and not an appliance repairman, so use this info at your own risk.

If you want to you could take off the outer door panel by removing the screws around the inner perimeter and either lifting a little up and out or swinging out, etc. Behind that is electronics that are powered so you may want to turn the breaker off to remove the power.

Near the top of the inside will be the latch, it could be buried behind what I’m going to assume is a reinforcement panel. Get the latch out and inspect it to see if there’s anything wrong or off and then try to operate it. You may be able to see if there is an issue with the latch or not.

I also took my digital multimeter and checked for continuity through the wires by touching the probes one to each side of the connector on the latch...

by

And then operating the latch mechanism to see if it was able to have a signal sent through the wires and be received on the other side and then back to other probe.

This may not fix your issue but it does rule it out and now know to look elsewhere for your issue

by

Show 1 more comment

Add a comment

I have had the exact same problem with my whirlpool gold dishwasher. It would fill with water, run through the first cycle, pop open the soap dispenser, then just sit... For hours. I replaced the door latch, then the interface (button circuit board), neither of those parts fixed it. It seemed like it had something to do with the house shifting with different seasons, and if I twisted the door Just right, it would catch again and complete all cycles. The other day I loosened the 2 screws that held it tight to the bottom of the countertop and it has worked perfectly since. My theory is that the tabs attaching to the countertop were holding the latch tongue at an angle which wasn't making good contact in the door latch switch. So now it's somewhat free floating. Maybe worth a try!

Was this answer helpful?

Score 0

Comments:

@celia omg...I have Had several service calls and each time they replace the sump & motor assy...and it is exactly what you say..something with this %#*@ door switch...if I slam it shut it works..if I tilt It just right it works...do I know How to repair the issue..no but you have helped me more than you know....I knew It wasn’t that darn motor. I knew It was electrical and not the darn pump. Thank you for your input..you are correct!!!!

by

@mcassell yes! It's a problem with the actuator not making good contact with the switch. I don't know how to permanently fix it, but now I know for sure it's not the pump motor assembly or the timer mechanism. I've found when it gets to that point and won't continue, if I push in and down at the center of the handle it usually catches and continues all the way to clean and dry dishes! Really puzzling, it's a shame because it's a great dishwasher.

by

I have the same problem. Replaced motor and assembly, and control board, did not fix the problem. Just looked at the latch and it looks like it’s latching properly. What is my next step? Can somebody help?

by

Add a comment

Add your answer

radicalng8 will be eternally grateful.
View Statistics:

Past 24 Hours: 107

Past 7 Days: 801

Past 30 Days: 3,583

All Time: 26,861