Repair guides and support for LED, LCD, HD and other Vizio TVs.

294 Questions View all

Pluto TV not loading through built-in app/Smartcast on Vizio display

Anyone experience loading issues with some of the built-in apps? Specifically Pluto TV doesn't load any videos and displays the three little dots as if it's loading, but it does display the tv listings so it's connected and receiving data. I tried resetting the display back to factory settings in an attempt to 'clear the cache', but it didn't work. It's just hung up on Pluto, which is a bummer because I've actually gotten use to watching it's content.

I have a Vizio E55-E2 4K Theatre Display with built in Chrome/Smartcast, purchased in 2017.

Answered! View the answer I have this problem too

Is this a good question?

Score 3

Comments:

I have the same problem on my E55 with Pluto only, all other apps working fine. Tried all the same things, help! Might be a global issue with Pluto on these displays, works ok on another TV in the house with Chromecast.

by

Same here. whats up

by

still waiting on Pluto to answer my email

by

works everywhere except vizio

by

Nice - it's back! Now my kids can watch their cat channel (good grief). Well it was helpful knowing it was not just me experiencing the problem - thanks!

by

Add a comment
New Battery = Faster iPhone
Fix Kits starting at $16.99

2 Answers

Chosen Solution

yes for 3 days. no word from Pluto yet. they know about it

Was this answer helpful?

Score 2

Comments:

not able to cast Pluto either

by

Pluto is working now.. sometime late last night it started working... so glad

Pluto never did respond to my gmail... that's kinda lame, I might add

by

still working. I guess they were listening

by

Add a comment

The Pluto TV app is crashing every time commercials start. The TV goes to CH 3.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Robbo4473 will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 40

Past 30 Days: 183

All Time: 353