Released on September 19, 2014, this 5.5" screen iPhone is the larger version of the iPhone 6.

1195 Questions View all

iPhone 6plus - replaced battery and now won't boot.

followed the step by step directions and replaced by iPhone 6 plus battery... all seemed to go smoothly, but now the iPhone won't boot (stuck in the apple logo loop on an apple usb charger).. and "waiting on iPhone" in iTunes restore mode connected to my 2016 iMac with current iTunes... GAH!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

decided to test it with the old battery and sure enough, boots up with the old battery... waiting on getting a replacement replacement.

by

phew... looks like i dodged a bullet with the Tri-star... got a replacement battery from i fixit and installed with no issues... booted up and ran fine with a normal drain during use before calibrating.

by

Add a comment

1 Answer

Chosen Solution

Most likely the new battery doesnt have enough of a charge to boot the phone. So, either the charging doc needs replaced or cleaned as it is not charging your new battery with enough charge to boot it or you have a board related (u2) ic chip problem and need to replace the (u2) Tristar IC to get it charging properly. If you can use a charged battery to test with, it should boot up and troubleshoot from there :)

Was this answer helpful?

Score 3

Comments:

i put the old apple battery back and it boots up fine and will charge from dead to to 100% (just not holding the charge for any length of time... which is why i needed to replace it), ... waiting on another replacement ifixit battery to see if the problem persists.

if it won't boot from the second ifixit battery, is it safe to say it's the tristar IC...? (and replacing THAT is beyond my novice skills...)

by

It would either be the Charging port or Tristar... but could have been just a bad battery replacement. If you have a multimeter, you could check the charging where the battery plugs into the logic board to see if it is sending a charge. But if your old battery is charging and your new one isn't...maybe just a bad new battery. Keep us posted and I will follow this post

by

phew... looks like i dodged a bullet with the Tri-star... got a replacement battery from i fixit and installed with no issues... booted up and ran fine with a normal drain during use before calibrating.

by

That's Great! Good Job :)

by

Add a comment

Add your answer

craig rousseau will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 76