Idea pad 305 wont charge

i have had my idea pad 305 for just over a year i purchased for a project which then never happened. i used it for emails and a few other bit for a short while. I then started using it when i needed to put parental controls on the family windows 10.

It ran out of power so i connected the charger and it never charged regardless of how long i left it charging. i then borrowed a charger from work which worked, it ran out of power again i used the work charger again and it wont charge at all i have since purchased a new charger and that does not work either.

Any help would be greatfully received.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

@pridu99 sounds like your battery is the problem. Most likely from the long time of having been discharged and now no longer holds a charge. Replace it and re-evaluate

Was this answer helpful?

Score 2
Add a comment

OMG!!

you would not believe it. I borrowed the work lead again and pushed it in quite firmly and it started working. I tried both the original and the recently purchased leads but they still wouldn't work. we tried all combinations too to ensure it wasn't anything really daft. I decided it must be the connectors and on really close inspection found that the work one was just over one millimeter longer than the other two. I shaved the plastic off the end of one and now its perfect.

Sorry to have wasted your time.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Barry will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 19

All Time: 19