Released September 16, 2016. Models A1661, A1784, and A1785. Available in 32, 128, or 256 GB configurations in Rose gold, gold, silver, black, jet black, and (Product)Red.

557 Questions View all

DFU reboot and invalid serial error (i7P)

Hi Community,

Got a phone given to me of a repairer. Original repairer killed the phone after a screen replacement. I have managed to get power to return to the device after a tristar change, however, the phone now boot loops into DFU mode.

I have attempted restore via itunes and it returns an error similar to "cannot find device" and using 3U which returns two errors:

  • "Unable to switch DFU mode to recovery mode" however phone goes into recovery mode, so i try flash again and get the next error
  • "Invalid serial number"

I have checked for any other errors on the board with nothing visible, no heat, tried restoring with no screen, new screen, new charge port, different cable and different PC all with no luck.

Any ideas would be great!!

Update (12/08/2017)

Anyone got any more info on this one?? Does anyone know which IC the serial details are stored in?

I did have to replace the '5750 intermediate frequency IC' , but dont see that having any impact on this....?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

The serial number is stored on the nand, so if the nand is corrupt it most probably can't read the serial number correctly, also the fact it won't go from dfu to recovery mode points to nand too. As when it entered recovery mode it starts to restore to the nand, if it can't find the nand at all it bails.

by

Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

4 Answers

Chosen Solution

So today i decided to get working on the iphone 7 again. Plugged it into my computer, same old errors. I just had an incling to try again on my mac (had tried in the past), hey presto.... the phone restored nearly the whole way and then threw error 3 towards the end.

Best thing was, when the phone reconnected, it had its serial number back again.

I plugged it into 3u and the phone started to restore again correctly, however, now is hanging at baseband install. More digging to do!!!

But thanks for the answers so far!

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

From what I have read (Not from experience) it is most likely caused by either a corrupt NAND or from overheating NAND during Tristar and caused bridge or cold solder joint. If you have the NAVIPRO 3000, you could remove it, reprogram and install, if not, you could reball and try again.

But this is from "Reading" about the issue and could be wrong...just an idea and would seek out expert advice from @refectio or @jessabethany before going to such extremes.

I did read on one post that to remove FMI if on but not sure if that would cause a SN issue.

Please repost answer you find I'd be interested in knowing what repair worked for you

Was this answer helpful?

Score 3
Add a comment

I would continue looking into the charging circuit. Boot loops, annoying, can happen from charging circuit issues. After that I would look into the voltage rails coming out of the pmic. You'll need a zxw tool for that. They're not expensive, and worth their weight in gold

Was this answer helpful?

Score 2

Comments:

Yep I’ve got ZXW. Unfortunately the model iPhone 7 it is is the one where there is least info about the device. I will continue to check but I assumed possible further power line isssues

by

I've got the file from a different one. Shoot me an email and I'll send it over

by

Want to shoot me an email - jacob@basixit.net

by

@fo22zz It is recommended NOT to post your email or other personal info here on iFixit. https://meta.ifixit.com/Answers/View/106...

by

Add a comment

Hmmm... Plugging the cord into the pc BUT NOT THE PHONE. then as your holding down the home button plug the other end into the phone.

THIS WILL RESULT IN DATA LOSS!

Was this answer helpful?

Score 0

Comments:

Was your answer about putting the phone into recovery mode? If so, being an iphone 7, wouldn't it be holding down the volume down button??

Didn't work either way.

by

Oops @fo22zz I forgot the iphone 7 plus is slightly different if you like you can mark me down a point.

by

Add a comment

Add your answer

Jacob Harvey will be eternally grateful.
View Statistics:

Past 24 Hours: 8

Past 7 Days: 44

Past 30 Days: 174

All Time: 4,138