Repair guides and support for your Mitsubishi TV, no longer produced by Mitsubishi Electric.

60 Questions View all

TV Screen Stuck on Menu Screen / No Sound

I have an older Mitsubishi 60 inch WD 65835. Turned it on today and there was no sound. So I was playing around trying to get the sound to work and went to the menu screen and went into Output for menu. It was set to Surround Sound, so just to check, I changed to Stereo. But when I did, the TV became "stuck" on this screen. Now I don't have sound, and can't even get off of this "Output Menu" screen.

I called the Mitsu Help line, and did a few things (unplugged, reset, hold power down and wait, etc.) but all to no avail; still stuck on this screen. Lady said I needed the remote control (and or course it has been misplaced... I was using the remote for my cable box instead). She said if I can't find, I'll have to call and have a repair person come out.

I just paid the 200 bucks to get the "white dots" fixed about 4 weeks ago; really don't want to spend money on the repairman again.

Anyone have a suggestion? I've unplugged for 30 minutes, plugged back... nothing... system reset, still stuck, power button hold/reset, still stuck.

Other?

Thanks much to anyone that could help me out!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

@buchanan0306 when you turn it on from a power reset what do you see? Is it always going to the same menu and getting stuck there?

by

Maybe I'm just crazy... but I was certain it was the TV, and even the Mitsu folks said was the TV. So I unplugged for about an hour; and turned on, reset the cable box, and it's fine now. So not sure it the unplugging worked, or if it was the cable box, but either way, it is fine now!

You were so quick to answer, I feel like I need something to have been wrong (WAIT, I didn't just say that! lol)

We're at a new house, and it seems that we have minor power surges and/or very quick power outages, and that has been screwing with the TV... so maybe that cause it? Not sure, but glad it is fine now!

And want to thank you much for trying to help me out!!!!

by

Good luck in your new house and welcome to iFixit!

by

Add a comment

1 Answer

Chosen Solution

@buchanan0306 definitely would be easier with the remote. Check the reset procedures from the SM as listed here:

Block Image

Try the system reset.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Anthony will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 12

All Time: 28