iPod classic works, but won't wake up again.


I actually have two iPods from the same gen, but I keep confusing which one it is. One of them is a black-fronted 80gb and the other a silver fronted 120gb. On the logicboard of the last one it is stamped 2008. I don't think it the latest gen, but I'm not sure. They are slim.

Anyways they both had their hard disk fail and when the second failed I decided to buy a new SSD to put in it. But in replacing it I managed to pull the battery connector bracket off. Thankfully I still had the other one, and the switch was successful. For a while. One day I had to push very hard to get it to wake up and the next day it refused. It woke up again later while I was tinkering, and it works fine as long as it doesn't get to go to sleep. The only way to wake it up at the moment is to pull the battery band out and put it back in again.

I have tried both of the batteries, and the same thing happens. I have looked at the front of the logicboard and I can see some corrosion (I think), but I have no idea if this is causing the problem, and I have tried cleaning it up. The strange thing is that the wheel and buttons work just fine as long as it is awake. I have also changed the click wheel itself and the problem persists. Reseting it is not possible either, as nothing works when it falls asleep.

Is there anyone that has a solution other than changing the logic board? I just can't afford that right now, and I don't know anyone that could solder a battery connector bracket back on the (presumably) better logic board.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment