Why is the sound fine but, screen very dim and blinking on and off?

IT worked fine last night and this morning you could hear the sound but no picture. Later we realized there was a picture but it was very dim and it would flash on and off. Picture then all black picture all black, but the sound is fine and channels change etc . Tried different inputs with the same results.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Most Helpful Answer

@edouble2369 this could be an issue with the main board or the power board. You would have to check the power board first. Post some images of your boards with your question so we can see what you see and identify the connector that you will need to test power out on. Use this guide Adding images to an existing question for that. Your power board should supply 12V and 19.5V for the panel. The cycling could be caused by bad capacitors as well as bad MOSFETS. Check your boards for obviously damaged looking components and that all cables are properly connected. Right now my prime suspect is the power board.

Block Image

Update (09/25/2017)

@edouble2369 failed LED backlight strips can cause this as well. Again need to see more.

Was this answer helpful?

Score 1
Add a comment

im no TV expert, but sounds like maybe a loose connection, a bad backlight, or both. the heat from normal operating may have made the port "push" the plug out.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Eric John Kamelamela will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 15

Past 30 Days: 34

All Time: 73