iMac 2 gpu cards.Can I activate nvidia 9400 after pulling out HD 4670?

Hi

I found out my iMac 21.5 late 2009 apparently had 2 graphic cards in it. A dormant nvidia 9400 integrated graphics in the logic board and a removable Radeon HD 4670 (on a mxm card).

Having in mind I had to 2 Gpus I took out the Radeon HD 4670 for another computer in need of a graphics card, but now the iMac screen doesn't come up although I can hear everything working in the background.

Is there a way to activate the nvidia 9400 that is integrated in the logicboard? Even if I have to put the other gpu back in to set this up (then removed it - as to the first idea)?

Other iMacs run only with nvidia 9400 (the standard one). How can I ask the iMac to use this one as the default one instead?

Many thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

There were three configurations of this machine and we need to know with one you have. However the on board video acts like a pre-amp. You still have to have the amp.

Video Card: GeForce 9400M* VRAM Type: Integrated*

Details: There are two configurations of this model -- MB950LL/A, which has a NVIDIA GeForce 9400M graphics processor that shares memory with the system and MC413LL/A, which has an ATI Radeon HD 4670 with 256 MB of dedicated GDDR3 memory.

UPDATE 9/14/17

A lot of would be very interested in seeing if you can get this to work.

You could potentially save hundreds of thousand of Mac from the dump if you can. So please keep us updated. I would do the research on this but I have been out of the office for 5 days at the iFixit un-conference and am swapped with students starting school. But try this discussion and let us know if it is a resolution:

https://apple.stackexchange.com/question...

@danj

could be a solution on the 2011 MBP with the bad GPUs

Was this answer helpful?

Score 2

Comments:

Hi Mayer

thanks for your answer. The model I have is the MC413xx/A one.

The MB950LL/A one (with just the integrated card) has the exact same logic board and the exact same connections, apart from the mxm card socket. Both have the same integrated card in the middle.

I wonder if it's possible to tell my iMac to only use the nvidia 9400 as it seems to be sufficient to run everything (proved by the MB950LL/A with only the nvidia card).

I thought the iMac would assume automatically it should use the nvidia 9400 in the absence of the other card but it doesn't seem to be the case.

Any ideas about how I could instruct the iMac to just use the integrated card?

Many thanks

by

Add a comment

Add your answer

Mr will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 8

Past 30 Days: 14

All Time: 42