Skip to main content

Repair guides and support for laptops produced by Razer.

129 Questions View all

Razer Blade 14" Early 2016 - Wont Boot From HDD or USB

I have a 2106 Razer Blade 14" Laptop that won't boot from the HDD or a bootable USB I made.

It starts, gives me the choices for Boot Menu, BIOS, and Recovery.

I can get Boot order options.

I can enter the BIOS menu.

Recovery take me to a screen that gives me an error code but I can't do anything with it.

In the BIOS menus I can see the HDD listed and the USB listed, but when I choose them as the boot option it exits the bios menu, puts the Razer logo on the screen for 10 secs, then goes to a black screen.

When its on the black screen I can see that the LED backlights are on.

I'd love to give you more info but I can't get into to computer.

Any ideas on where to start?

I was going to replace the HDD but the fact that it won't boot from a USB either made me think that might be a waste of time.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

same problem. Did you find a solution??

by

I have the exact same thing, however I'm out of warranty from Razer and they told me it could cost about 1000usd. I feel so cheated. I don't know what to do

by

wow how did you get that model? its just 2020 and the 2106 model is out?

by

Old post but I'm having the exact same issue, strangely I can boot a live Linux usb fine but windows from CD or usb created fresh twice and nothing, 10 seconds of logo 3 seconds of load wheel and nothing.... Any other tips?

by

I hace the exact same issue, have you solve it?

by

Show 7 more comments

Add a comment

2 Answers

Chosen Solution

Hi,

Don't know your laptop's BIOS options but did you ensure that the one of the following options in BIOS (appropriate to your laptop) has been enabled to allow it to boot from a USB, assuming your laptop is running Win 8 or 10?

1. Legacy Support.

If you have Legacy Support listed, make sure it’s On or Enabled.

2. Legacy CSM.

If you have Legacy CSM listed, make sure it’s On or Enabled.

3. Launch CSM.

If you have Launch CSM listed, make sure it’s On or Enabled.

4. CSM.

If you have CSM, make sure it’s On or Enabled.

5. UEFI/Legacy Boot.

If you have a UEFI/Legacy Boot option, make sure it’s selected as Both or Legacy Only.

Was this answer helpful?

Score 2
Add a comment

Was a known issue and razer actually fixed it well out of warranty, had it back over a year and alls fine

Was this answer helpful?

Score 1

Comments:

My model's newer though; I believe mine's the Razer Blade Pro 15. Also, this happened after 2 years of use and one of the errors mentioned was a corrupted file named "\winload.efi" I'm trying to boot using a USB now. I believe RMA-ing during these times are a bit impossible considering the circumstances. :(

by

Add a comment

Add your answer

Aaron will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 22

Past 30 Days: 61

All Time: 10,265