Won't power up - dead

Hi All, I have a Panasonic LUMIX DMC-TZ6 camera that won't power up, I have tried 2 fully charged battery's that work on another camera, taken it apart and cleaned with switch cleaner spray the on-off switch, and sprayed the camera/playback switch,and still no joy, so I presume a fuse has gone inside somewhere ? Anybody know the location of any fuses ? There is a battery under the top cover ML421 that's reading 0.48v is it rechargeable or do I replace it ? Hopefully I will find time later to have another go at it. Cheers Stuart

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Hi Tony, Thanks for all of that, don't know the history of the camera as I bought it at a car boot sale (garage sale) I didn't notice any corrosion/water marks inside, like you say its surface mounted components which are a bit more tricky, thanks for the circuit diagram/manual at least I can follow the power track and see where it stops. Cheers Stuart in UK

by

Add a comment

1 Answer

Most Helpful Answer

Hi Stuart. Here is the service manual for your camera:

https://elektrotanya.com/panasonic_dmc-t...

It is unlikely that a fuse has failed within the camera. Most cameras use surface mount re-settable PPTC fuses, which require no replacement. That tiny battery you are talking about is the CMOS battery for the camera which is responsible for maintaining the data and time of the camera. 0.48v seems low, but That won't prevent the camera from turning on. Try looking through the service manual for how to take apart your camera to give you a better idea of the repair process and then go from there.

Has your camera been dropped? Has it been exposed to water damage? There is a good possibility that a ribbon cable is loose internally and by re-seating it into the connector will make the problem go away. I had a similar problem with the Panasonic DMC-LF1 camera where an internal ribbon cable got loose and the camera refused to turn on.

Good luck!

Was this answer helpful?

Score 1
Add a comment

Add your answer

Stuart wilson will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 15

All Time: 15