Gopro wont turn on and flickers red when plugged in

Hi, sorry for the long post, I just included everything I could think of incase it helps.

I bought a spares and repairs original gopro hd hero off ebay, listed as just not turning on.

I've been trying to find out what's wrong with it but I've come to a point where I don't know what to try next.

Here's what I've done so far:

When I got it a few days ago I tried plugging it into a 1 amp usb plug. As I insert the usb into the gopro the red light on the front flashes but once the usb is fully in, the light weakly flashes for a few seconds or just goes straight out. Wiggling the usb around in the port on the also makes the light flicker. I've tried leaving the usb part way in to keep the light on but it always just flashes once then goes out. Strangely, the light also flickers when I turn the plug on at the wall, without touching the usb.

I have just now used a voltmeter across the positive and negative battery pins while the camera is plugged in without the battery to see if any power is getting through them. Suprisingly it measures around 1.4 -1.6 regardless of whether the red led is on or off. Wiggling the usb around in the gopro does make the voltage jump down the 0 and back up again.

Does this mean that the usb port is not in fact completely faulty and some power is actually going through to charge the battery?

After the gopro wouldn't charge through the usb port (at least I'm assuming it's not charging as the red light doesn't stay on) I assumed that the usb port must be broken and it's not turning on because the battery is dead and can't be charged. So I bought a wall charger to charge the battery externally. I used that to fully charge the battery (I also made sure that it was fully charged by checking with the volt meter). The gopro still won't turn on and behaves exactly the same as before.

To find out if maybe the battery is just broken I would need to try another battery, which unfortunately I don't have. I do however have lots of 500mah 3.7v lipos for micro drones so I made an adapter for one of those so I can connect it with the +ve and -ve battery contacts on the gopro - see pic. Even powering it like this it wouldn't turn on.

Or would using a makeshift battery like that never work, and should I just buy a new proper battery?

Would it be worth trying to power the gopro through the hero port?

Thanks a lot for any help at all with this!

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Thanks for the reply. Yes the battery is original gopro. I'll try and open the camera and look inside.

by

I put this in a draw and forgot about it for I while but I've just had it out and finally managed to remove the screws using solder.

Inside it doesn't look too great - there's a bit of white corrosion stuff and some screws are rusty.

Do you know if there's anything I can test to find out where the problem might be?

[image|1294922]

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Most Helpful Answer

Good analysis! Since you charged the battery completely and tried it in the camera, and the camera did not turn on it is likely that something else is wrong with the camera.

Question: is the battery you have a genuine gopro battery? It is more likely for a genuine camera battery to communicate properly with the camera than a knockoff. I think the gopro 1st gen just straight up used 3.7v phone batteries to decrease the cost of production of the camera. If your battery is registering around 3.7v - 4v fully charged than the battery is probably working fine.

I would give the camera a look inside to see if anything else is broken. First look for any lose cables or broken components. See if there is any mechanical problem causing the electrical problem. See if the circuit board looks damaged (damaged circuit components). Try comparing your board to photos of others online.

Here's a partial teardown of the original gopro:

https://www.fictiv.com/blog/posts/gopro-...

Good luck!

Was this answer helpful?

Score 1

Comments:

I've got a problem with opening the gopro - two of the screws came out very easily but two seem completely stuck and have unfortunately become badly burred. Any tips on removing them?

by

Is there a chance it could be a software issue and a factory reset would help?

by

Hi Tristan. I am not sure about the stripped screws. Sometimes when a screw strips and it is close to the exterior of a case, I will take a hack saw and cut in a groove so I can use a flat-head screw driver to get the screw out. You may need an extraction driver or follow another guide on the web for stripped screw removal. Good luck!

by

Add a comment

Add your answer

Tristan Gale will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 7

Past 30 Days: 19

All Time: 41