Gaming laptop released in 2015. Features an NVIDIA GeForce GTX 960M and 1080p 15.6" display.

15 Questions View all

Screen won't turn on, but everything else seems fine.

Some background info: I have a Lenovo Y50, I believe it's the y50-70 variant, but I'm not 100% sure. It's a 15.6inch with an i7, 16gb ram, sata drive, and an Nvidia 860m with 4gb of graphics. It was purchased in September of 2014, so it's a fairly early model of the y50. it's a bit beat up, but hasn't had any major functional issues to this point.

Now to the actual problem: When I boot the laptop, the keyboard backlight and status lights on the front all come on like normal, but the screen stays black (not just a black image being displayed, the screen is off). The problem has occured in the past, but was intermittent and could be fixed by letting it sit unplugged with the lid closed (I have no way of knowing if this actually helped, but it usually booted after that) for a few minutes before trying to boot again. The problem now seems quite permanent. I removed the backing last night and took a closer look, and the connections all appear to be fine. I'm not sure if it's relevant or not, but the laptop was left unplugged and powered off for about 72 hours before it refused to boot. The status light indicates that it still has battery, and I've tried it both with and without having the charger plugged it. I've also tried it with an external monitor without success.

My initial inclination is that there is a problem with the graphics card, or some other internals rather than the screen itself, but I really have no way of knowing, as hardware isn't my area of expertise. I'm a CS student, so if anyone could post answers ASAP, it would be VERY much appreciated.

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

You could do what the person who answered suggested, but if you would like to find out what's causing the issue let's get a few things out of the way first: if your GPU is causing the problem or not. There is one way of testing: hook your laptop to an external monitor, a TV anything. If something shows up there, it's not the GPU, but something else, likely the LCD cable (not the backlight or the panel itself).

by

Add a comment

1 Answer

Most Helpful Answer

Saw this thread and wanted to post a potential solution, as I had the same problem recently:

You can try resetting your computer by holding the power button down for ten seconds, then releasing. The next step would be to open the computer and disconnect the main battery for 10 seconds to reset it.

However, if you keep the computer plugged in for long periods of time, especially if you live somewhere with a dirty power source (for example, I live in Mexico), your computer may have locked itself up to protect itself from a power surge. The good news is, this isn't a mechanical failure, it's just a security mechanism.

In this case, you need to open the computer, disconnect the main battery, and find a smaller, 3v battery on the motherboard that starts the BIOS (this is a small, round object just above the main battery on the MoBo that says something like "CR2032-3V-etc" and has a red and a black wire coming out of it). To reset the BIOS battery, you unplug it from the MoBo just like you did for the main battery, wait 10 seconds and plug it back in. Make sure you ground yourself before working on the computer.

If this solves the problem for you, then to prevent future failures, you'll need to buy at least a new surge protector and ideally a voltage regulator or no-break system, as this means you have an unsafe electrical current charging your computer.

Note that if you are still getting the splash screen (the Lenovo logo appears on your screen for a couple seconds before the computer shuts off), the error is probably somewhere else.

Was this answer helpful?

Score 1

Comments:

Thanks for the reply, I now believe that the error may not be the graphics card exclusively. The Lenovo service rep had me see if the Caps Lock and Num Lock keys work. They don't, which indicates something a bit more widespread. Might be the power supply or the motherboard, but it's probably not the GPU or display

by

Add a comment

Add your answer

Brent Heavey will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 8

Past 30 Days: 33

All Time: 33