Where are the diagnostic LEDs on the iMac mid-2011 27" EMC 2429?

I've searched as much of the internet as possible for a good few hours and not found anything concrete, so apologies if this is answered elsewhere just described slightly differently...

But where exactly are the diagnostic LEDs on a mid-2011 27" iMac? EMC 2429 model A1312.

I've found basic diagrams showing where they are on 2009 and 2010 models (bottom left of the logic board) but I don't have any there on my 2011 model- I suspect they moved to up and right of the middle of the board.

I presume my PSU is as dead as a dodo as there are no signs of life whatsoever, and I've had all room lights off in case the LEDs are obscured from view in any way. I've taken pics of the internals to check- general view...

Block Image

And of what I presume are the LEDs I'm looking for...

Block Image

The LEDs are labelled LED501 to LED504, presumably these map to LEDs #1-#4 as I've seen reference to elsewhere? The fact is- they're dead, so I'm assuming it's new PSU time...?

Cheers for any help,

The Lemming

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Ok, well I can answer my own question- yes those are the right LEDs. All I did was wiggle the connectors again, and purely out of curiosity plug it back in and not only did LED #1 /501 light up, when I pressed the power button the whole %#*@ thing burst back into life. Typical.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Mark Whitehead will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 23

All Time: 23