Released September 25, 2015. Model A1688/A1633. Repair of this device is similar to previous generations, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 64, or 128 GB / Silver, Gold, Space Gray, or Rose Gold options.

873 Questions View all

Missing PP16V5_MESA voltage on iPhone6s

In my quest to repair my daughter's iPhone 6s, I now find that the PP16V5_MESA voltage is missing from the J4100 connector. Unfortunately I know this voltage was fine before (the screen worked), and I apparently affected something while finding and repairing a shorted capacitor in the PP2V75_MAMBA_LDO circuit.

I found the shorted cap (C4121), but only after removing U4100 and surrounding components FL3202, C4128, FL4107, C4106, FL4105, FL4120, C4124, and Q3140. I was not trying to remove them all, but one moment of shaky hands while the hot-air was flowing and the next thing I know there are parts flowing everywhere. Grr! And C4121 was so easy, way out there on the edge of the board... If only I had known that was the failed cap before... double grrr.

I ordered replacements for everything and managed to reflow all the parts listed above. It looked like it all went well, however I think U4100 did not solder correctly because I'm still missing PP2V75_MAMBA_LDO output (the input to the LDO is a good 3.8v PP_VCC_MAIN).

But the bigger problem is PP16V5_MESA is now missing. The only component in the PP16V5_MESA circuit that is near the U4100 LDO is FL4107, which is one of the parts I accidentally removed and put back. I checked both sides of FL4107 and it is 0V, so it looks like something upstream towards the PP16V5_MESA LDO.

Anyone have any suggestions? Is there a common-mode failure for PP16V5_MESA?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

MESA doesn't have anything to do with the screen, it's for the TouchID sensor in the Home button. If you want to properly test FL4107, you should test it in resistance/continuity mode to see if it good. A ferrite bead should measure essentially 0 Ohm across it's two terminals. Any kind of resistance would point to it being damaged.

You'll also want to measure PP16V5_MESA relative to ground to see if that output line is shorted. Could be a bad capacitor on the line, or something got moved (and possibly bridged) when everything else got blown away. I would also inspect the components in the MESA circuit (U4040) to insure all the passives are ok. MESA is essentially a Boost Converter so the switching coil has to be in good shape as does the PMID capacitor.

Let me know what you find.

Was this answer helpful?

Score 2

Comments:

Ah, well, I saw 16.5V and thought that must be the back-light voltage, but I see that is on a completely separate connector and is about 35V (and is also missing). That's what I get for assuming. The display and touch worked before I started messing around the MAMBA U4100 area.

I tested FL4107 to ground, and it was open (as expected), and tested across FL4107 and it was a short, also as expected. I tested the voltage on FL4107 and it is 0V. I tested all the caps in the MESA U4040 circuit and nothing is shorted, and across all the filters are shorts. The input to U4040 (tested on C4040) is a good PP_VCC_MAIN. The output of MESA U4040 is 3.8V instead of the expected 16.5V.

After checking around the other connectors, it appears I'm also missing PP5V7_LCM_*. I wonder if there is anything in common to all of these? Is it possible to mess up all these voltages by messing around in the MAMBA U4100 area?

by

Are you measuring the MESA output with a Home button connected?

by

No. After doing the reflow of the MAMBA components I connected the screen (which is new and known to be working prior to this last repair) and powered up the phone. There was no display. I disconnected the battery and display (all three connectors), then started checking for additional shorts. Not finding any shorts, I connected the battery and J4700 (to be able to use the power button on the case) and powered up the phone to start testing voltages. Do I need to test the MAMBA and MESA voltages under load (i.e. with the screen attached)?

by

I reconnected the display (all three connectors) and measured the voltages. All readings were the same as before, still missing 16.5V MESA voltage, PP5V7_LCM_* voltages, and MAMBA voltage. I also removed and installed a new U4100 last night and still no MAMBA voltage.

I wish there was a way I could test the enable input to U4100 so I could tell if it was being told to shut off. But the enable comes from the CPU and there does not appear to be any place to test the signal. The input to U4100 is still a good 3.8V PP_VCC_MAIN.

by

Add a comment

Add your answer

matthew will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 7

Past 30 Days: 33

All Time: 97