Why is my battery taking hours to charge?

Hey guys,

I bought a refurbished MacBook Pro Mid '09 at the end of 2012. About 3-5 months ago I noticed odd patterns with the battery drainage - the first 2 months, once the battery got below 40%, the laptop would turn off immediately and I'd have to power on again. Then as time went on, it became a lot more random, and I basically had to have it plugged into the power adaptor ALL the time, unless I wanted to be super risky. I also noticed that the power cord's green light was a bit touch and go, depending on the angle it was on. I tried resetting PRAM + SMC, but it didn't help at all. I eventually read enough online to feel confident that it needed a replacement battery (which, yeah, it's 8 years old, so it made sense!)

So I took it to an Apple certified repair shop, they had to order a special battery in (the mid-2009 body is considered 'vintage.') They've put in the the new battery, but I've had it plugged in for over 24 hours, and it's taken that time to get from 24% to 91%. The green light that usually shows on the power cord has stopped working, except when it's at an even odder angle than before the battery was replaced. The charge symbol up on the top menu bar has the symbol that it's charging, but when I click it, it says "Battery is not charging," but that the source of power is the Power Adaptor.

Again, I tried a PRAM + SMC reset just to be sure, but it didn't help at all.

I installed coconut battery to see what's up with that, and here's the info, if that helps:

Current Charge: 5235 mAh

Full Charge Capacity: 5766 mAh

90.8%

Design Capacity: 5770 mAh

99.9%

Manufacture Date [battery]: 2011-01-27

Cycle Count: 2

MacOS battery status: Good

Battery Temp: 32.8 deg celsius

Charging with: 1.64 watts

Power Adaptor: Connected

Manufacturer: Simplo

I also noticed, around the same time the initial battery went haywire, the speakers also have been super fuzzy, like the bass part of it has blown. Again, could be because it's old, but I'm also starting to think maybe it's the logic board or something internal like that?

Any help/advice would be HUGELY appreciated. I'm a student and can't afford a new laptop, so trying to see if there's an affordable way to sort this. Apart from that, the computer runs amazingly.

Thanks heaps!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

@mayer @theimedic this one's for you guys.

by

have you tried a new power cord?

by

Hey! Yah, tried a new power cord, same results. I think the answer below might be worth a try. Thanks anyway.

by

Add a comment

1 Answer

Chosen Solution

Your battery only has two cycles on it. It may need to be reconditioned. To do that let it run all the way down and then fully recharge it a couple of times. Then recheck it with your Coconut Battery.

Was this answer helpful?

Score 2

Comments:

Hey, thanks!

This is very possible, and I didn't even consider. I'll see what happens and update if needed :)

by

Add a comment

Add your answer

Amber Liberté will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 6

All Time: 50