Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus.

3060 Questions View all

Won't charge, loosing signal, headphones jack doesn't work

I replaced lightning connector and after that I have problems with charging. Phone was not charging as fast as before,it's taking a very long time to charge. When I watch something on phone and it's connected to the charger, my battery is still dying. Then I realized my service is not as good as before after I replaced the part. And when I use headphones, there is some noise and button on it doesn't work.

I replaced the part just because charger was loose in lightning port, nothing else wasn't wrong

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

It sounds as if you either purchased a faulty charging port or there was a mistake during installation. The ribbon in the port has circuitry traces that run through it and if flexed too much, can sever or damage those traces. As you are probably aware, the headphone jack, Charging and cellular antenna are all part of the port assembly. My suggestion would be to reinstall your old port, paying attention to the loose charging port to try to secure it better during reinstall and return the new one provided you are confident there was no damage or faults in its installation. If your old one works fine again, my theory is "Don't fix it if it's not broke" ;-)

You could make another attempt with a new one if you believe the loose port is not fixable with old one. Best of luck!

Was this answer helpful?

Score 0
Add a comment

I put a brand new part and again I have the same issues :Slow charging, loosing service (or poor service) and sometimes noise in earphones. Is it possible I did something during installing the part?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Marko Knezevic will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 15

All Time: 35