Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus.

3053 Questions View all

NO Image with backlight ON, Itunes sees it

I have an Iphone 6 that was experiencing ghost touch. I replaced meson and cumulus after testing a known good LCD and no change in symptom. I changed both again to make sure there was no mistakes and still no change. I began testing voltages with screen attached when I noticed home button would not work... So I powered down, resat the connectors and when I powered back up again, I have a backlight but black screen. I tested with another lcd and same thing on it. It draws power, charges battery, Itunes sees it, just no image and crazy readings around Mesa and bad readings around Chestnut and Tristar.

I changed Chestnut U1501 and U1503 along with C1501

Getting the following:

BL Coil is 1, Diode is .204v, resistance to ground is .507v

VCC_Main = 4.2v

FL2035 LCM to Chestnut and FL2036 AP to LCM Reset are good = 1.8v

FL2095 PMU to Photon Alive = 1.8

P17V0 Mojave _LDOIN C1501 = 3.8 (That's why I changed it and U1503, No Change)

L1500 PP18V0_Mesa (1 and 2) = 4.2v (Another reason to have changed U1503 No Change)

C1500 and C1503 getting 0 to crazy numbers on Voltage

L1519-1 getting 4.2v good VCC_Main but not boosting to 6v on L1519-2 (Is why I Changed Chestnut U1501, No Change)

C1541 = 5.1v

FL2037 PP5V7 (C2050) ... = 5.7v

FL2061 PN5V7... = -5.7v

FL2027 PP1V8...= 1.8v

C1299-1 PP3v3_ACC 3.3v missing on Tristar U1700 (Replaced Tristar with no change, Getting VCC_Main around Tigress U1401)

I was able to restore on Itunes without errors... except I have a Backlight with no image, tested with other LCD's

I also replaced Data Filters L2041, L2042, L2043, L2044

any ideas?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

You don't mention it specifically, so just to be certain, did you disconnect the battery first?

I would look at all of the associated filters (on page 21 of the schematic). There are also some MESA filters on page 22.

Update (08/21/2017)

When looking for shorts, the "normal" way to probe is to set your meter to resistance mode or continuity mode. Then set your black probe to a ground or reference point and the red probe on what you are measuring (you can reverse the probes but by convention, black is ground/reference). What this does is tell you the resistance between the two probes.

When troubleshooting digital circuits, Continuity Mode is used primarily for detecting short circuits. So when we test voltage rails, we don't want "continuity" to ground, we want to see high resistance or OL conditions. Some voltage rails, like CPU/GPU rails are low resistance so they may make some meters beep so you have to look at the measured value to properly interpret the information you are receiving.

Your descriptions below are correct except that you never tried to measure the actual resistance of the rail, relative to ground. You tried the following:

  • (1) continuity mode...it beeps from ground (Shield) to Cap ground --> This is normal (they're all connected together)
  • (2) Diode mode, with red on ground (shield) and black on ground of cap, I get 0.000v --> normal (see above)
  • (3) Diode mode with black on ground (shield) and red on ground (Cap), I get 0.000v -- > normal (see above)
  • (4) Diode mode when I put red on ground and black on (Rail) + side of cap, I get 0.577v -->normal if you are probing a component that has a digital IC in parallel
  • (5) Diode mode when I put black on ground (Shield) and red on (rail) + of cap, I get 0L --> normal if you are probing a component that has a digital IC in parallel

The results of Number 4 & 5 above suggest to me that the rail is good and not shorted (you are not seeing 0.00V) but it may still be partially shorted, we still don't know for certain. The only mode you haven't mentioned, and it's the one I am asking for, is as follows:

  • continuity mode...black probe on ground (Shield) and Red probe on the Rail side of cap --> This is the one you want to use to see if there is a short on the rail and know what the actual resistance is.

Louis Rossmann wrote a great guide here (https://www.rossmanngroup.com/importance...) on how to use Diode Mode for troubleshooting. Lots of repair techs use this but they don't all truly understand the measurements they are seeing. It's not a silver bullet but another tool in your toolbox and the data it provides must be interpreted to be useful. Louis and other successful techs use this technique because they have seen dozens/hundreds/thousands of boards and noticed the small variations and their correlation with issues and resolutions. By themselves, the numbers don't mean much. Most people would be hard pressed to even explain what the meter is doing to the circuit when it is testing in diode mode.

A useful analogy to Diode mode (see #4 above) for testing is like trying to understand the traffic conditions on Broadway by only looking at the traffic going in and out of Manhattan via the Lincoln Tunnel. If you had dozens of "Manhattans", you could probably infer something but on it's own it's not conclusive.

When starting out, learn to do the simple stuff "well" and then add more advanced tools and techniques as you go along.

Was this answer helpful?

Score 2

Comments:

@refectio Yes, I did power off and disconnect battery first. I have a charging port and battery as well as test screen I use while testing board out of housing.

I also tested every cap and filter around Digitizer, LCD, Home, R Cam and F Cam FPC's

by

C1501 should measure 17V and your MESA output is obviously low. Do you have an original Home button connected with an active and recognized TouchID scanner?

Also don't measure resistance to ground in diode mode. Sure, it's interesting when comparing boards or if you have documented enough repairs to know what that value should be. But the number it generates doesn't tell you the resistance unless you calculate mentally, knowing what current it is injecting. Put your meter in resistance mode and tell me what the actual resistance is.

by

@refectio Yes, I am using the original home button with touch ID, I can't tell if it is working currently since I have no image. However, It was working before this happened. I'm sorry about the measurements... I am still learning the differences. I turned it to the "Autoranging" and C1501 gives me 000.1 and 000.2 back and forth on the resistance mode. Where do I find what these readings should be and would the lack of 17v effect the image? Or just Touch ID??

by

No need to autorange, you're looking for shorts. Set it to the lowest range (200 Ohms) so you know what you're reading. If your meter only has an auto mode, than look at what it says on the screen: Ohms, K Ohms, M Ohms etc. That way you will know what 0.1 means (0.1 MOhms is not the same as 0.1 Ohms).

If you are seeing 0.1 Ohms on C1501 (P17V0_MOJAVE_LDOIN) then you have a problem.

by

@refectio I added a pic of my multimeter, I think I have a problem, because it doesn't have a setting, only auto range and if I hit the range button, it gives 000.0 on M Ohms, 000.0 on K Ohms and 000.1 and 000.2 on Ohms. I pulled the IC and it reads 000.0 What does it mean?

by

Show 18 more comments

Add a comment

Whoa, that's a LOT of needless complexity on this question.

Simplify.

Eliminate variables.

Solve one problem at a time.

Troubleshoot no image. #1 cause = long screw damage. This is the first thing you check WAAAAAAY before all this rabbit hole nonsense.

Forget about various ways to use a multimeter--pick one and stick with it. Forget about tristar 3v3_acc. Forget about mesa. Forget about touch ics. Troubleshoot no image and just no image.

Remove mesa

Remove meson

Remove cumulus

Does it boot?--detected by iTunes in normal mode?

If yes, does it have image?

If no--does it have LSD? Fix LSD until you have image.

Once you have image--go after other problems, touch, then home button.

Was this answer helpful?

Score 2

Comments:

Thank you @jessabethany , There was no Long Screw damage...They were pristine. I removed Meson,Cumulus and Mesa with no change (no image). It is detected by Itunes, was able to restore without errors. all the correct voltages were there except the L1501 boost to 6v. Replaced Chestnut, L1501 with no change. I changed all the data filters and the FPC...I got a backlight, but no image. I decided it must be CPU damage after several days of running down the "Rabbit hole" because I tried everything I could try. I already scrapped the board tonight but your advice is well appreciated...and will follow it down my next venture :) Thank you very much for your reply.

by

Add a comment

Add your answer

Michael will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 8

Past 30 Days: 37

All Time: 173