Guides and support for various TV brands and styles.

2181 Questions View all

TV Powers On, Sound OK, Half screen green while other half is good

Power, screen and sound work fine on my Samsung un65eh6000. However after cleaning the TV screen with fine (over)spray of Windex left half of the screen has now gone green. At first for like 30 mins after wiping, it earlier appeared smudged, then we saw some ghosty black snakes all across the screen, then the whole screen turned white and now the right half of the screen is all Green while the right half seems to be OK. I took off the back cover and panel etc.. and am now to the board level. The two cables from TCON board to the bottom of the TV have been disconnected/reconnected multiple times but no change. I did see some water droplets (must be Windex) at the bottom of the TV where a few circuit PCBs run that connect to the main screen with very fine band type cables, but i did blow them dry. Also, without any signal, the entire screen goes blackish/blue and I can see the hue light lit at the back. So the LCD is good. However the moment I connect the ribbon cables from the TCON board to the LCD circuitry that lies at the bottom of the TV, the left half of the screen remains black with the "No Input" text box displayed on the screen but the right half of the screen turns all green. I have attached a few pics with my post to explain the situation. Hope the pics give you a clear idea and picture of the above explanation ..

The 4th image from top was taken after I disconnected both the ribbon cables from TCON board to the bottom circuitry. As you can see that all screen turns black with a slight hue on the back throughout the panel, which tells me that the LCD/LED screen is still working good. Its some issue either with the ribbon cables or the TCON board.

The 5th image was taken after only the right (bad) side's ribbon is disconnected but the left side ribbon is intact. In that case I do see a small white line on the extreme right side of the screen, which was not there (as you can see in image 4), when both the ribbon cables where disconnected. I guess it may a result of the left screen info. overlap.

The 6th image shows the back of the TV when it is ON showing all 3 boards and the glowing light of the screen.

The 7th/8th/9th images are that of the TCON/Input Source/Power board respectively.

Any help / suggestion will be very much appreciated.

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

@sudhs usually when one side of the panels is out this is related to the complete loss of drive data for all RGB information to the right side of the screen. This is sometimes caused by the flat cable connecting the TCON to the LCD panel coming loose or having been damaged. The area of missing video can be dark or completely white depending on the panel design.

So check your cables and if those are seated properly and show no damage, your most likely failure is the T-con board. It is not a panel error.

Was this answer helpful?

Score 3

Comments:

Thanks for the tip Oldturkey.. I got the new TCON board along with the set/pair of band cables. I also spray cleaned and re-seated the LVDS cable coming from the input source board to TCON. Looks like whereas the pair of band cables are now feeding the signal properly but the re-seating of Source board to TCON board seems to have screwed something up and now random lines appear sometimes on the left/middle/right side... Looks like I will have to order a new LVDS cable now. But your confirmation that panel is still intact helps and gives me a breather for now. Thanks for your inputs and comments. Will keep posted as time goes on.

BTW.. I tried reseating the LVDS cable again but it kinda behaves weird. Sometimes the screen is green, sometimes turns blue,, sometimes everything vanishes.. blah..blah..blah..

Do you know if the pair of BAND cables that go from the TCON board to PANEL have some kind of polarity/directional orientation or can they be placed in any direction ?

by

No polarity but you cannot turn them or anything like that.

by

Add a comment

Found this on youtube.

https://www.youtube.com/watch?v=ZtyhKHDw...

Was this answer helpful?

Score 1

Comments:

Thanks for the link Elle. I just noticed that the fine threads of the band cables going from tcon to screen are kind of damaged and worn out.. Ordered a pair on ebay. Will check and post once I receive them.

by

I can't even simulate the same screen that I posted earlier anymore. Looks like something else went bad between then and now.

by

Add a comment

Add your answer

Sudhanshu Grover will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 12

Past 30 Days: 68

All Time: 166