Released September 25, 2015. Model A1688/A1633. Repair of this device is similar to previous generations, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 64, or 128 GB / Silver, Gold, Space Gray, or Rose Gold options.

914 Questions View all

New screen works, but blanks when assembled to the base

I have my new screen attached by the cables to the logic board, but not fully seated to the base. Kinda like a clam shell. The phone boots up and works fine at this point. However, as soon as I start seating it to the base, the screen cuts off, but everything is still working fine. The screen is blank, but all the other functionality is working. I can even navigate (from memory) to apps. I normally just have the phone open after doing a screen reinstall then shut it off to do the final installation steps, but I wanted to see when it was doing this after the first time I sealed it up. I seems like the act of pressing the screen to the base causes it to go blank. I have tried to reseat the connectors to the logic board and that hasn't worked. Any help please?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Most Helpful Answer

Well I found out the problem. The screen is definitely defective. I installed the old cracked screen and it worked fine. This is actually a second screen iFixit sent me after the first one was defective as well. I am beyond frustrated.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Daniel Furey will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 18