Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

510 Questions View all

Laggy on Mac OS, but not on Bootcamp.

Hey everyone,

Specs: i7, 16gb of ram

I replaced my hard drive with a Samsung Evo since I thought the hard drive was damaged. I also replaced the cable. It'll start off okay on the Sierra OS side, and then start lagging terribly. I then struggle to shut down the computer because moving the mouse and clicking becomes very sluggish. Absolutely do not have this problem on the Windows 7 part of the hard drive. I can use the computer fine for hours. Any idea what this might be?

Thanks, much appreciated

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Before getting deeper into possible hardware problems I'd try the easy road by creating a new user, logout from current user and log into the new one. If the lag is still there then it's possibly a system issue or a hardware problem. Try also resetting PRAM by pressing together command+option+P+R at startup until you hear a second boot chime.

Was this answer helpful?

Score 3

Comments:

Hi Abraman,

Thanks for replying. I've tried to create a new user, and resetting the PRAM. It didn't solve the issue. It's weird because I can use the Windows partition without any issues. I don't really mind, but it'd be nice to be able to use the Sierra partition as well.

by

In order to rule out a possible system issue a clean Os install would definitely be a troubleshooting option. Other than that, we would probably get into a hardware failure. There's a number of machines with your specifications having shown similar symptoms after an hard drive or a battery replacement. If you have the original install disk you could try a hardware check and see if that exposes a problem. It might be a temperature sensor returning invalid infos to your Mac and keeping your processor busy with a kernel task it cannot complete properly. If you manage to open the activity monitor to list all running processes you'll probably find a stuck kernel task process sucking all computing capacity. Such instructions set is not present in the windows Os, therefore it runs properly in bootcamp.

Let's see first if a clean system install fixes the issue.

by

My buddy reinstalled the OS. He eventually took out the battery and it's running ok now. It's throttling the processor and GPU from what I understand without the battery, so got a new battery on the way. Hope that's all that needs to be done.

by

If you get a good battery, problem will be probably solved. Not so unusual battery logic or sensor goes bad and causes Cpu throttling.

by

Add a comment

It sounds like a reinstall of Sierra might help, give it a shot.

Was this answer helpful?

Score 0
Add a comment

Add your answer

gary will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 7

All Time: 91