Microsoft's third-generation Xbox game console, released November 22, 2013.

251 Questions View all

There's a Game disk Stuck in the disk drive

I have a xbox one that i got in Janurary of 2015 that has my copy of just cause 3 stuck in the disk drive. Every time i try to get it out it dosen't work. I've tried using an allen key to manually eject it 4 times and i've tried using the eject button to get it out. When i try to play it it says there is no disk in the drive, and when i press the eject button, it makes a very loud and worring noise that sounds like it's trying to eject and accept a disk at the same time. Can someone please help?????

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

You have to disassemble the drive, the drive mechanism is misaligned.

Was this answer helpful?

Score 1

Comments:

Thanks man,thats what i thought i had to do, just wanted to be sure. Only problem is i don't have the tools to fix electronics so i will have to go 15 miles. But oh well you probally don't care so yeah.

by

Normal ifixit screwdrivers or equivalent will do, as long as there is no actual component level failure.

by

Add a comment

Add your answer

James Bunch will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 4

All Time: 63