The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3615 Questions View all

Phone stuck on Apple logo, just vibrates when plugged in

This morning, I woke up and found my phone both unresponsive and very hot to the touch. I tried to turn it on, but was greeted with only a black screen. After waiting a little while, I took and plugged the phone into a different charger. It began to vibrate every few seconds, though the screen remained black. Oddly enough, it had not been vibrating like that when I woke up, despite being plugged in. I plugged it into a couple more chargers, including the one I'd used last night, but to no avail; it wouldn't do anything but vibrate when plugged in.

At this point, the phone had cooled down to average, or even below average, temperature. I booted up my laptop and began searching for solutions to my problem, where I saw many threads discussing this. One user suggested resetting the phone by holding the power and home buttons. I followed their advice, and saw the Apple logo appear on my screen. Of course I was elated, but then the Apple logo didn't go away. It just... stayed there. When I plugged it in, it continued to periodically vibrate, just with the Apple logo rather than a blank screen.

Others suggested plugging it in to my laptop to perform a reset. I did, but it just continued to vibrate, while iTunes told me that it had received an invalid response from my phone, My phone normally is locked, I'm not sure if that may affect it. Then I was advised to hold down the power and home buttons, resetting the phone; then let go of the home button and hold down the power and volume up buttons; then just hold the volume up button until the screen came on. Needless to say, that didn't work, either.

So, I'm at a loss. I know nothing about hardware so I haven't tried to open the phone up or anything, as I wouldn't know what to look for, anyway. At present, I'm sitting here with a cooled-down but unresponsive phone, emblazoned with the Apple logo and nothing else, which vibrates whenever I plug it in. Anyone know how to solve this problem, or if it even is solvable?

Answered! View the answer I have this problem too

Is this a good question?

Score 3


Update: I just plugged it into my portable charger with a fourth cord, and it's not vibrating, strangely. I had gotten it back to a black screen by holding down the power and home buttons again, and when I plugged it in the Apple logo reappeared without my pressing of any buttons.


Add a comment

4 Answers

Chosen Solution

This sounds more like a hardware problem than software. The charger it was plugged into overnight, is it an Apple Original brick and Lightning cable? Cheap chargers and cables can cause the charge circuit in the phone to blow.

I would suggest that you start by taking it to a reputable repair shop in your area to have it looked at. It could just be the battery but it may also require a micro-soldering repair. Not every repair shop offers micro-soldering repairs so you would have to search for one locally or mail it in to a specialist in that event.

Was this answer helpful?

Score 4
Add a comment

This happened to me as well, the only difference being I was using the phone when it happen. I suddenly just when to an all black screen with a little loading spinney thing, at fist I though it was updating but then it did that for about 10 min. and I got worried. Then tried the same thing you did and got the same result...

Was this answer helpful?

Score 0
Add a comment

I'm surprised nobody mentioned trying to restart the phone using home + power button for 10 - 15 seconds then turning it on again.

Was this answer helpful?

Score 0
Add a comment

Ok, so the same exact thing happened to me on my iPhone 8 Plus on iOS 11.

I called Apple Support and they had me do this:

1. Press the Volume Up button once

2. Press the Volume Down button once

3. Press and hold the Power button until the phone restarts and you see the black Apple logo against the black background.

This fixed the issue for me right away. I couldn’t find this process anywhere online, so I’ve posted it here for the next unlucky soul that runs into this issue.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Jacob Dussere will be eternally grateful.
View Statistics:

Past 24 Hours: 20

Past 7 Days: 107

Past 30 Days: 454

All Time: 3,646