Released June 2012 / Core i7 processor with Turbo Boost / Up to 1 GB DDR5 Video RAM

361 Questions View all

Will not run on MagSafe power adapter if battery is installed

I have this MBP 15" Mid 2012 that someone spilled some water on. I have no idea how much because they removed the bottom cover and put it near a fan and then turned it on (against my advice, why do people do that?)

I blew it out with a compressor and it runs fine but when the battery is installed, it won't charge or run off the MagSafe adapter, it only runs off battery. If I remove the battery it will run off the MagSafe.

I have tried some resets, etc and even a new battery.

Any suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Mac RAM Kits
Speed up your Mac. Max out its memory.
Mac RAM Kits
Get more memory out of your Mac.

1 Answer

Chosen Solution

Sadly your logic board has some damage within the charging logic.

You could try installing: coconutBattery which will allow you to see thats happening here.

There is a set of MOSFET's that switch the power feed from the MagSafe adapter to the system and the battery as needed controlled by SMC. You'll need to find someone with the tools and skills to diagnose what needs replacing and has access to the needed parts.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Rob Santone will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 38