PLEASE HELP! Post-logic board replacement, having issues.

Hey MacBook gurus.. Ready for a puzzle? So, here's the story. My buddy spilled coffee on his computer, it "turned off immediately," but I had him do a hard shut down anyways to be safe. We drained everything out, and dried everything off. Apparently he tried to turn it on again (against my recommendations), but nothing happened. I took it home and took it apart, cleaned the logic board, keyboard, and everything else I could get to. Still nothing. So I told him his logic board was most likely fried. Replaced the logic board, MagSafe board, keyboard, battery, and RAM. Now I get the prohibited sign (picture attached), and it wont boot past that screen. Here is a summary:

1.) New logic board, battery, RAM, keyboard, MagSafe board

2.) hard drive works (plugged it into my computer, and it booted up fine)

3.) keyboard works

4.) fans on high when turning on the computer (tried resetting SMC, but computer wont turn on after resetting.. so I have to hold the power button for 5 seconds, then press power again in order to turn on)

5.) MagSafe indicator stays green

6.) was able to boot from CD, and disk utility does see the hard drive, but doesn't have it as an option to boot from

Block Image

I think that is it.. Please, anyone have any suggestions!? I'm stumped here.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Please tell us your exact machine and what OS X is loaded on the hard drive. Is this the original hard drive that was in it before the spill and has the system been changed outside of the machine?

by

Early 2010 13' MacBook Pro OSX Sierra

Samsung SSD 250gb (not original, but the same HD as when the spill happened)

I've tried using the same HD on the computer, but it wont boot past screen. Works on my computer though, which is weird. Recently formatted the HD and tried booting from a USB startup boot disc OSX sierra installer. When I choose USB boot option it goes straight to prohibitory sign again. Is that enough information?

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Had you checked on this?

https://support.apple.com/en-us/HT204156

if possible, try to backup and perhaps format and reinstall the os and see if it helps.

Was this answer helpful?

Score 2

Comments:

@salmonjapan I've noticed your answer this late last week and they are pretty good and I've been voting you up. The only thing I've noticed is that you are not getting the facts you really need first before giving an answer.

by

@mayer, noted about it and I will try to improve on it

by

@salmonjapan I have looked at that article before, and a lot of other websites/forums that talked about the prohibitory sign. I haven't actually reinstalled the OSX yet, but have been having a hard time getting the computer to recognize the boot file on my USB, since I don't have the OSX CD. Thank you for your reply!

by

Add a comment

Add your answer

Tyler Walkah will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 12

All Time: 60