Skip to main content

MacBook Pro models with 13" displays

9049 Questions View all

MacBook Pro won't install any OS.

I've C/P my post from apple support so I don't have to write again.

Hi, I have a late 2009 MBP 13'' 2.26 that originally came with 2*1 GB of RAM and a 5400rpm 160GB disk. I've upgraded the disk to Western Digital Scorpio Black with 320GB @ 7200rpm and also RAM to 2*2GB g-skill ddr3. From that time my computer started to act funny and kept being sluggish and it became pretty annoying. I had to do a fresh install on zeroed-out disk but that helped till last week. Then it started to appear again and made me do all the fsck -y, repair permissions, disk verifying, and all sorts of thing found on the internet.

So I've decided to copy some of my Logic projects onto a external disk and that took an eternity to copy 949MBs. Same thing happened with other disks/usbs. When it finally managed to copy the 949MB at a speed of one legged ant I've decided to do one more fresh install.

But first I made a hardware test that told me every piece of hardware was OK.

Moving on, I've formatted my disk and started installing SL. It is as fast as Michael Phelps in swimming pool but exactly the opposite.

It has literally been installing SL for 3 hours by now. And it still says 14 mins left, same as 50 minutes ago.

P.S. I managed to install 10.6.6. update thinking that it might do the thing, but when the install and reboot was complete it was time to log on. I typed my password and the blue screen would appear, just the one that appears before the log on screen. Then the log on screen appeared again. This game of ours has been stopped by a gray screen telling me that I have to shut down my computer by holding power button.


When the installation of SL was finally done I've immediately tried to update to 10.6.6. The update was downloaded, but during the installation of update it froze on "moving items in place".

Then I tried to install WIN 7. It did the install but when I wanted to put bootcamp drivers it froze on ethernet installation. Everything else seemed to work properly.

Then I've put all the stock parts back in and started a fresh zeroed-out install on my original 160gb hitachi hdd. No luck there. Installation freezes at "29 minutes left" ,same as before.

I've used original RAM in both cases.

I'm thinking of mainboard fail ?


hardware tested the machine with 4gb of gskill and got error at

4MEM/9/40000000: 0xac10bf98

is this a bad mem chip ? And since it's not working with stock memory is it possible that this memory ****** up memory slot and thus no memory can work properly ?


Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Try one stick of the original RAM only. Try in both slots.

Start up from the original system installation disk and hold down the "D" key and let it run. Let us know your results and we can go from there.

Was this answer helpful?

Score 3
Add a comment

Add your answer

darko dujmovic will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,043