always showing send service so what is the fault howcan solve this pro

my kenwood car stereo K D C-u2263R always showing send service so how can solve this problem i did reset the system but not changes

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Kenwood equips its receivers with a protection mode to safeguard them. Your stereo receiver is going into protection mode because the receiver has an internal short, a speaker is bad or the speaker wiring has a problem, such as incorrect wire gauge or bad connections. Many of the problems that trigger protection mode can be resolved or at least diagnosed by tech-savvy owners, without bringing your car into the shop.

Step

Reset the receiver by removing the face plate and pressing the "Reset" button with a paperclip. If this solution doesn't fix the problem, continue with troubleshooting and reset the receiver after each step.

Step

Turn off the receiver and disconnect all speaker wires.

Step

Turn on the receiver. If it quickly shuts off, the receiver has an internal short, according to Kenwood. Contact Kenwood customer service to have the unit repaired.

Step

Connect one speaker at a time. If the receiver shuts off after connecting a speaker, that speaker's wiring or the speaker itself has a problem.

Step

Replace any faulty wiring.

Step

Replace a speaker if you have replaced its wiring and your receiver is still going into protection mode.

Was this answer helpful?

Score 1
Add a comment

Add your answer

raphealthomas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 8

All Time: 14