Skip to main content

Repair guides and support for motorcycles manufactured by Harley-Davidson.

63 Questions View all

2011 dyna running rough,speedometer not working

2011 wide glide running rough but idles fine and speedometer is not working

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

3 Answers

The two issues very likely are connected. The serial communication bus connects all the modules, and the engine management system manages your ignition timing and idle speed control differently if you're moving vs rolling. Often the engine will stall when coming to a stop when the speedo has failed. First define what you mean by "not working" on the speedo - not registering speed? Odometer not displaying or not advancing properly while riding? Backlight not lighting up? Needle whipping about violently? Cure the speedometer issue and there's a good chance it will run better.

Was this answer helpful?

Score 0

Comments:

I have this same issue. My 2011 FXDWG speedo will roll up on the initial start up but will not register speed. It idles perfectly fine but stalls out and pops in 1st and 2nd gear.

by

Add a comment

2013 Dyna wide glide speedometer stays on 0, not working. Gear ratio stopped working but rpm’s are still working. Stalls when coming to a stop!

Was this answer helpful?

Score 0
Add a comment

The ECM needs the speed signal from the speedometer to manage idle speed, so it’s common for the engine to stall in that situation. First test the speed sensor, hope that’s all it is. If the speed sensor is good, the speedometer itself can be bad.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Chad whittaker will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 21

All Time: 692