The PowerBook G4 was initially announced at Steve Jobs' keynote at MacWorld Expo in January 2001. Its body was made mainly of Titanium and had a 15" screen.

172 Questions View all

Is intel processor needed to install snow leopard on my G4?

I have a PowerBook G4 with 10.5.1 (Leopard). I need to upgrade to snow leopard in order to get the new apps available on iTunes for the mac. It states that an intel processor is required! what can I do?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

thank you. it's a bummer. I have this naive way of thinking that if i've been a faithfu mac user and now an iphone user, i should be get a "free pass" around the obsolescence. :(

by

Add a comment

2 Answers

Chosen Solution

You can upgrade (FOR FREE) to a maximum of 10.5.8 on your machine. Snow Leopard requires an Intel processor. I have an Intel processor and looked at some the Apps offered today. There was nothing I couldn't live without. Outside of surfing the internet there's just not much I do today on my Mac that I couldn't do twenty years ago. Granted there are some games that just won't run on a Mac+. The rest is planned obsolescence to make you go buy something new that you really don't need.

Was this answer helpful?

Score 3

Comments:

Now theres the truth. I just bought a Pismo for $44 that does everything I require in a laptop. +

by

Add a comment

No chance of getting Snow Leopard to run on it. This machine is old by computing standards and there's no support for running Snow Leopard on PowerPC-based machines.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Rhonda will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 3,371