Sixth iteration of Apple iPhone, announced on September 12, 2012. Repair of this device is similar to the previous models, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Black or White.

3122 Questions View all

Stuck in recovery mode

I have a old iPhone 5 which has been stuck in a draw for some time. It got slightly wet when I went for a run in the rain. Anyway I fixed a iPad mini after being messed around by a repair shop and kinda got the "I can fix anything bug"! So I ordered a new digitiser and battery and away I went. I striped it right down. Took out mother board and soaked it in alcohol. There were no obvious signs of corrosion. Put it all back together and plugged it in. First the Apple logo appeared and I was delighted. Then the power cable sign and iTunes came on. Looked on net for what was happening and saw that it was in recovery mode so plugged into iTunes. iTunes dose not recognise the iPhone and told me to make sure I am running the up to date version. So uninstalled and re did. Still get the same message. So I tried to reboot by plugging in cable and removing when Apple sign came on to see if it was something to do with pry damage but it won't do it. Can anyone shed some light. I know it's not really worth it but it is to me as it's a project I started and would like to try and fix myself.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Well let's just hope you allowed it enough time to dry, after soaking it in the ip. Four or five hours should be more than enough. After that I would put it into dfu, and restore to a backup

Plug your device into your computer with a USB cable.

Turn off the device.

Hold the Power button for 3 seconds.

Hold the Home and Power buttons for 10 seconds.

Release the Power button but keep holding the Home button.

Was this answer helpful?

Score 1

Comments:

i left it overnight to dry after the soak. I'll give it another go with your suggestion. But I am sure Its not recognising the home and power button. Which is why I thought I may have done pry damage.

by

Add a comment

Add your answer

Karen amatt will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 36