The Lenovo S21e-20 Features a small, 11.6" display ideal for a student or a commuter.

6 Questions View all

Keyboard doesn't respond after pressing Caps Lock.

Keyboard works normally until pressing the Caps Lock button. Hitting Caps Lock will make the keyboard unresponsive, you won't be able to type anything after. Can't even open up on-screen keyboard to turn off Caps Lock since it (on-screen keyboard) will hang on startup. Right now, it looks like restarting is the only way to bring back the keyboard.

Really confused what the problem is. And my Google searches aren't pulling up this specific problem.

I should add that ONE key does respond after pressing the Caps Lock key: the Fn or Function key types the number one (1.) Aside from that, nothing else works.

And it looks like opening the on-screen keyboard and turning on Caps Lock on it works normally. No keyboard hangups. No issues with turning on/off Caps Lock.

Problem is when Caps Lock key is actually turned ON using the keyboard. That's when everything stops responding. Even the on-screen keyboard stops responding though it's working beforehand.

Answer this question I have this problem too

Is this a good question?

Score 3
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

3 Answers

Most Helpful Answer

Hi Jarell,

This really is a strange problem, first time I am hearing about this too. Let's quickly do some troubleshooting.

Firstly are you running windows, if you do, lets open Device Manager by pressing Windows button + R to open the run box, then type devmgmt.msc. Go down to Keyboards right-click on each driver under the Keyboard section and click uninstall. Reboot the computer and see if the problem continues.

If the problem does continue, plug in a normal USB keyboard and repeat the steps, if nothing happens and everything works 100%, the problem might be the laptop keyboard. I suggest taking it to the nearest computer repair store to be replaced.

If you want to replace it yourself I have attached a link to the keyboard via Amazon

Hope this helps and let me know if you come right


Was this answer helpful?

Score 3


Hey there,

Just uninstalled the keyboard driver and then restarted. Problem persists. But hear this, the same thing happens on an external keyboard. Pressing Caps Lock on the external also stops both external and built-in keyboard from responding. Which makes me think it's a software issue. But on the other hand, you can turn off Caps Lock from the external keyboard but not from the built-in one.

Edit: I was wrong. Pressing Caps Lock on the external keyboard stops ONLY the built-in keyboard from responding.


It does sound like the built-on keyboard is faulty or defective (with the caps lock problem) best is to change it. If the laptop is still under warranty, contact Lenovo for assistance for they will exchange and repair it for free.


I've never heard of this ever either. You could try doing a fresh install of windows, but you would lose all your data unless you backed it up. I also don't think laptop keyboards don't cost much. And if it still is under warranty, you can get I replaced and fixed for free.


I guess I'll try reinstalling Windows first. If that doesn't work, we'll probably send it to get it fixed. I'll do my best to get back here afterwards.

Thanks, guys!

P.S. Still open to other suggestions.


Awesome, hope the Windows reinstall fixes it, best of luck and let us know if you came right.


Show 5 more comments

Add a comment

My computer is Thinkpad X220t.

However, I have the same problem: when the Caps Lock key is off, everything works fine. When the Caps Lock is on and the led is lit, the system starts behaving erratically. Some windows freeze, other keys render wrong characters (ex euro E), etc.

I'm using Ubuntu Linux.

I suspect this problem is generated by a short circuit on the keyboard. Before ordering a new keyboard, I was wondering if you solved the problem and how (software, keyboard replacement or motherboard keyboard connector problem?) . I would appreciate a quick answer.

Many thanks.

Was this answer helpful?

Score 0


Hello. I suggest reading the comment thread under my question. Another user had the same problem and solved it by disconnecting and reconnecting all wires.

As for me, I just disabled the Caps Lock key using a keyboard software I found online.

Best of luck!


Thanks, Jarell. Much appreciated.


Add a comment


My Lenovo 510 yoga started having the same problem right now. How did you fix it?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Jarell will be eternally grateful.
View Statistics:

Past 24 Hours: 10

Past 7 Days: 73

Past 30 Days: 347

All Time: 6,890