2.0GHz, 2.3GHz, or 2.6GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.8GHz) with 6MB shared L3 cache.

166 Questions View all

Blank screen / no image after replacing the display assembly

Hello,

My display was broken and I bought a new Display Assembly Replacement and changed out the part. But now the display remains black and shows no image. I have tested with two new displays, both the same. Please help me, what can I do??

Sorry for my bad english.

Thanks for your help

Steeve

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Make sure you are buying a display for the correct year; 2012-2014 A1398 LCDs are compatible (although 2012-early 2013 and late 2013-2014 assemblies use different camera connectors, the picture should work fine). 2015 A1398 LCDs will not be compatible at all.

Check around the LCD connector and the LCD cables of the assemblies to ensure you haven't chipped the cable or burnt any components. If you did not unplug the battery, this is very likely to happen.

Shine a bright light onto the screen to see whether you have a no picture issue or a no backlight issue.

Verify the assemblies you bought are definitely not faulty. There is currently a shortage of LCD panels for the A1398s, so it wouldn't surprise me if the not 100% new assemblies sold on eBay, etc are worse quality than usual.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Steeve will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 39