Thinkstation C30 not booting, seems bricked

I have a Lenovo Thinkstation C30 that has both Ubuntu 17.04 and Windows 7 on it. A few days ago, while using it, the system froze and wouldn't respond. I did a hard reboot, but when the system attempted to boot, there was no startup beep, no BIOS screen, and the boot counter (inside the system) was stuck at zero.

I then began disassembling the PC and testing the parts to try and find out what happened. It seems like all of the components (RAM, hard drive, CD drive, etc.) are all operational, and the system seems to "boot", but there's no output at all.

System is a used Lenovo ThinkStation C30 1095, with 8GB of RAM, an Intel Xeon E5-2630 processor, with a dual boot instance (Ubuntu 17.04 and Windows 7). I've used it for 6 months with only one issue before (RAM became unseated during shipping and led to a situation similar to this, but I was able to fix it just by putting it back in.)

Thanks for any help!

Answer this question I have this problem too

Is this a good question?

Score 2


What have you tried? Have you tried a CMOS reset?


Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

1 Answer

I suggest resetting the CMOS.

This is done by removing the CMOS battery on the motherboard (the little silver circle) and leaving it out, with the system not plugged into power, for at least 15 to 20 minutes.

After that, put the battery back and just have the motherboard, CPU, ram, PSU, and GPU connected. (Only use the GPU if your motherboard doesn't have onboard graphics). DO NOT plug in any fans but the one for the CPU cooler, the hard drive, and optical drive. Also, dont plug anything in but the monitor, if it boots and you see an image, shut it down and then add a keyboard and mouse. If it still works, then plug in the Hard drive and Optical drive.

If nothing I just said helps, let me know and we can further diagnose your PC.

Was this answer helpful?

Score 0


I tried removing the CMOS battery and rebooting, with no effect. Lenovo's documentation recommends using a jumper pin to reset the CMOS, but my system doesn't have any such pin (see


Have you tried just whats needed to run the system? Do any of your fans spin or do you get any indication anything is getting power?


Fans and most parts of the system seem to turn on and get power, but after clearing the CMOS it only runs for a few seconds before rebooting.


Do you have another mother board to check the components?

You might need to check with old board new parts or check old parts with new board.

If your getting nothing at all, sounds like the board might be dead.


Your board might be dead, We will talk about this later.


Add a comment

Add your answer

javathunderman will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 8

Past 30 Days: 24

All Time: 582