The Samsung Galaxy S4, model i9505, features a 13-megapixel rear camera, and a 5-inch 1080p display.

625 Questions View all

nothing appear on screen , tried to replace the screen and still same

Hello

i got a galaxy s4 which is not turning on

i plugged the power supply to check if the motherboard is working , and i got a sign of Amperes meter of 0.25 and varying, which mean the motherboard is ok but the screen was not showing anything

then i tried to see if the problem were the cables , but they were fine , none of the copper terminals of the cable was damaged

after that i tried to replace the screen , but still the same problem , its not showing anything

is my method of checking is right ?

and what could be the problem now , did i miss somtihng ?

please help me to fix it

thanks

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Most Helpful Answer

try this

Remove the LCD cables, Place some windex on a napkin, wipe the connectors. There might be some windex left on the

connectors, so get a dry napkin and dry off. Make sure you put back the conncetors correctly and it should work. It did for

me. I only removed the battery to avoid a short circuit. and the plate that covers the LCD connector so you dont have to

tear the whole thing apart. GOOD LUCK. Hope this helps some of you.

Was this answer helpful?

Score 1

Comments:

didn't work mate :(

by

The S4 vibrates for a second when it turns on and shows the notification led at top left to show it boots up. Do you at least get a vibration noise when attempting to turn it on?

0.25 is too low. It should be pulling at least 0.4A and higher to indicate the phone has turned on and is charging up the battery / device.

Sounds like a dead power management chip on logic board to me. If you tried a known good battery (charged) then you either need to find someone that replaces that power management IC chip or give up on that phone.

by

hey ben

tried it but there were no vibration , and no led light

and i checked again for the current , it was 0.4 actually when i pushed the power button , it stayed for 5 seconds then it went back to zero , then back to 0.4 and remained for 2 sec , then back to zero , all this process while me still pressing the power button

what do you think is the problem ?

by

Add a comment

try replacing the battery might resolve the issue.

Was this answer helpful?

Score 0

Comments:

tried it , also the same problem

by

try, changing the motherboard that may resolve the issue.

by

Add a comment

Add your answer

Hesham Adwan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 34