Released on September 19, 2014, this 5.5" screen iPhone is the larger version of the iPhone 6.

867 Questions View all

Not Responding to Touch

I received a 6 Plus that woud not charge or power on for repair. I replaced U2 (TriStar) and Tigris... After receiving about half the voltage it should, I tried to power it up but still would not power up. I double checked for shorts and found one near Meson IC. I removed Meson IC and Short went away, so I replaced it with new one. No Short now.

Now, Phone boots up fine but not responding to touch. It is a tested Screen that works, no damage to Digitizer FPC Connector so I removed Meson and tried another...Still same issue (Not responding to touch). Any suggestions on what to check next?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

I'm sorry, I was going back through my old questions and noticed I never followed up on this one. It ended up being a bad capacitor (C2402) PP5V1_Grape... :(

Replaced it and worked fine from there :)

Thank you for your help and time

Was this answer helpful?

Score 2
Add a comment
Most Helpful Answer

You should also replace the Cumulus touch IC as well if it's still not working as shown here:

http://www.microsoldering.com/iphone-6-p...

http://www.microsoldering.com/wp-content...

As shown in that link the iPhone 6+ has two touch IC chips that should be replaced when it suffers from the touch IC issue.

Was this answer helpful?

Score 4

Comments:

Thank you, I should have mentioned that I did replace the cumulus as well as Meson, PMIC, Tigris and Tristar.

by

You have to check the integrity of the M1 pad under Meson. Most shops are now strengthening it with a micro-jumper regardless of it's condition. Here's a great video https://www.youtube.com/watch?v=U2UMCzP3...

by

I did have to use the M1 Jumper in past repairs after the pad tore loose during desolder wick...but I did not do it to this repair, as I thought the M1 had to do with the Grey Bars and the Cumulus type effect. Does M1 jumper help "Touch" issues?

by

"It" is touch disease.

by

Okay, I have removed Meson...ran jumper on M1...put on new Meson. I have also replaced Cumulus, PM IC, Tristar and Tigris...Still have no touch. I replaced Meson again...No touch. I have verified the LCD/Digitizer is good. I did notice that the A8 CPU is getting unusually hot as well as a few coils surrounding CPU.

Any ideas on what to check next?

by

Show 1 more comment

Add a comment

Add your answer

Michael will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 30

All Time: 124