Released April 2010 / 2.4, 2.53 GHz Core i5 or 2.66, 2.8 GHz Core i7 Processors

502 Questions View all

MacBook mid2010 A1286 won't go to sleep.

I changed the hdd flex with the sensor, with no luck.

checked the screen top area, magnets are in place... checked with a magnet on palmrest, won't sleep!

Is there a board chip handling this I should look at?

Thanks in advance!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Fresh install of Mac OS Sierra.

All on default.

Just replaced the HDD and IR sensor flex... with no luck!

Not the white bit with orange flex

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Test after each of the following steps that you haven’t already tried:

Step 1

 ▹ System Preferences ▹ Energy Saver ▹ Power Adapter ▹ Wake for network access: uncheck. You may need to unlock the preference pane by clicking the lock icon in the lower left corner and entering your administrator password.

Step 2

 ▹ System Preferences ▹ Energy Saver ▹ Schedule… ▹ Start up or wake: uncheck

Step 3

 ▹ System Preferences ▹ Print & Scan ▹ Open Print Queue...

Check all printers for unfinished jobs. Deal with any you find.

Step 4

Disconnect all wired peripherals except keyboard, mouse or trackball, and monitor, if applicable.

Step 5

Launch the Activity Monitor application in any of the following ways:

☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Activity Monitor in the page that opens.

Select All Processes from the menu in the toolbar, if not already selected. Enter “powerd” (without the quotes) in the "Filter" text field. Select the powerd process and click the Quit Process button in the toobar (stop-sign icon.) In the sheet that opens, click Force Quit. You’ll be prompted for your administrator password. The process will be relaunched immediately.

Step 6

Boot in safe mode and log in. The instructions provided by Apple are as follows:

Be sure your Mac is shut down.

Press the power button.

Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.

Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

Note: If FileVault is enabled under Mac OS X 10.7 or later, or if a firmware password is set, you can’t boot in safe mode.

Safe mode is much slower to boot and run than normal. Don’t launch any applications at first. If sleep still doesn’t work properly, back up all data and reinstall the Mac OS. After that, if you still have the issue, make a “Genius” appointment at an Apple Store to have the machine tested.

If sleep now works as expected, go on to the next step.

Step 7

Still in safe mode, launch the usual set of applications that are running when you have the problem, including your login items, one at a time, testing after each one. Some applications may not work; skip them. You might be able to identify the cause of the problem this way.

Step 8

If sleep is still working after you’ve launched all the usual applications, reboot as usual (not in safe mode) and test again. If sleep still works, you’re done, at least for the moment.

Was this answer helpful?

Score 3

Comments:

it is actually the magnet on top of hard drive cable sensor that's gone bad, used same display and same cable on another palmrest, sleeps like a charm!

by

Add a comment

Add your answer

SERVXCESS will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 11

All Time: 73