The eighth generation of the Mitsubishi Lancer.

30 Questions View all

No power when pressing on the gas

I have a 2002 Mitsubishi Lancer OZ rally 5 speed. The engine runs fine but when i put it in gear it has a bad slow acceleration, and little to no power through any gear i put it in. and if i try to push the pedal to the floor it acts like there is nothing there and the RPM gauge redlines and the car revs high but the car doesnt move. It doesnt jerk or anything. i dont have a problem getting it in gear but was told it could be the clutch or slave cylinder. Ive checked the air filter and even removed it and took it for a drive and still same thing. check engine light is on but says that a O2 is bad.

Update (04/29/2017)

its a manual

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Hi @geneeakins ,

To me you've answered your own question. If the scan shows a bad O2 sensor that could be the problem. The ECU uses information from sensors such as this one to control how the the engine behaves. With wrong information regarding air intake it will react accordingly.

by

If you can, follow the clutch cable to where it termanates. Take some photos. Adding images to an existing question

by

Hi @geneeakins ,

Does the engine stall immediately if you release the clutch with no accelerator? If so the clutch is good. If it takes a little while to stall the clutch is slipping. (Make sure that there is nothing close in front of the car when you test this out).

by

when i release the clutch i took a few before it killed it and i was told it was a hydro clutch unless i was told wrong

by

i was thinking that maybe the converter was getting clogged but its not choking the motor. the motor runs great

by

Show 12 more comments

Add a comment

2 Answers

Chosen Solution

@geneeakins ,Gene, It sounds like the clutch may not be fully engaging, may have oil contamination on the disc, faulty pressure plate/clutch disc worn out, release bearing hanging up, possibly sticking slave cylinder(see if clutch fork is being pushed by cylinder pin) pin/push rod should have slight free play when clutch pedal not depressed.etc.. Since I am not actually to see/test the vehicle another problem could be a broken CV/axle joint which when broke will allow transmission to free wheel and car will not move(normally there should be some noise though, grinding/rattle). To check this jack up/support the car with the one drive wheel at a time in the air and attempt to spin wheel by hand, if it spins the joint will be broken, repeat on other side to check. If CV/axles are good, have a good local tranny shop diagnose and estimate clutch repair. If wanting to do the repair yourself your really should have a good manual with you when doing the job to reference. I posted a link below which does have the good basic instructions to do the clutch repair if needed. If not wanting to attempt the repair and CV/axles are good, have a good local tranny shop diagnose both clutch cylinders and estimate clutch repair. Good luck. I hope this helped you out, if so let me know by pressing the helpful button.

https://www.evolutionm.net/forums/lancer...

Was this answer helpful?

Score 3
Add a comment
Most Helpful Answer

Yep, sounds like a really slippery clutch. Or something​ wrong with the axle. Is it manual or automatic?

Clutch diagnosis and repair for your Lancer. 2002-Lancer-Clutch.pdf

Was this answer helpful?

Score 4

Comments:

Some thing fishy going on here team member @oldturkey03

by

@pccheese @lpfaff1 just added the manual to the answer. The kid had the right idea last night....

by

Okay. How's the clutch petal feel, normal? And is the shifting sloppy?

by

it feels normal it doesnt slip when i put it in gear but ive tried putting it in low gear and releasing the clutch and also in high gear and it doesnt want to move

by

@oldturkey03 great manual, thanks.

by

Add a comment

Add your answer

Gene Eakins will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 8

Past 30 Days: 25

All Time: 227