Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

493 Questions View all

Spill - Replaced Magsafe - Replaced Battery - Still not charging

So the title says it all. It was a spill of saline solution (don't ask). I don't think much got inside. I dried, washed with alcohol, replaced the magsafe dc board (bought from ifixit), and tried a different battery (from the same exact model 2011 Unibody) and still no luck - battery won't charge. Tried multiple chargers. Everything else works perfectly .

AHT says logic board is fine. Local shop ran graphics and logic board test as well and it passed.

I think I've combed through every question on this forum and think my only recourse is to either replace logic board, or get it repaired somehow. It just doesn't make sense to spend the $450 on an apple repair. If anyone has other ideas it would be greatly appreciated.

Otherwise, anyone have a list of shops that can fix logic board components?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

What exactly does the battery status show top right? If it has a percentage, but is not increasing, I would try another known working battery to rule this out. If it is showing a cross, there is an issue on the logic board, where the SMC is not communicating with the battery properly.

Have you checked and cleaned any liquid from the logic board using 95%+ isopropyl? Have you tried disconnecting the battery indicator too (can cause interference with the SMC>battery circuit if liquid damaged).

Give us some more details and we will be happy to help. It is most likely a logic board fault unless it is what I mentioned above or you are trying faulty parts. AHT is pretty useless too so don't rely on that.

Was this answer helpful?

Score 2

Comments:

I left pics in post below. Thanks.

by

Would recommend checking SMC_BC_ACOK signal and charging chip area. Will definitely be a logic board issue if the battery is pulled from a working MacBook, where it was charging fine, and the DC port is definitely not bad.

by

Thanks for the reply. Here's some screen shots of battery status:

[image|1093154]

[image|1093155]

[image|1093153]

- Like I said, I pulled the same exact Apple battery out of a different Macbook and tested it, there was still no led on magsafe, and not charging.

- I replaced magsafe dc board (from ifixit)

- I did clean with alcohol multiple times

I will try disconnecting the battery indicator and see if it charges. The only time I got any activity on the charger led was after I reset SMC and powered on, there was a quick flicker on the magsafe.

Thanks again...

by

Add a comment

Add your answer

SMR will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 6

All Time: 129